HOW TO USE THIS DOCUMENT

This document provides a few options.

1. You can read the brief Quick Start Guide, which gives you the basics of creating a schedule.
2. You can use the Walkthrough Tutorial, which helps you schedule a simple league step by step.
3. You can browse the Table of Contents or Index to find the topics you’re looking for.

Still, you may find it more engaging to watch a screencast that introduces the basics of scheduling in video format. You can find those movies here.

Let’s get started!
Table of Contents

How to Use this Document .................................................................................................................. 2
Quick Start Guide ................................................................................................................................. 7
Step 1 - Create a Division .................................................................................................................... 7
Step 2 - Create Teams ......................................................................................................................... 8
Step 3 - Create a Venue ....................................................................................................................... 8
Step 4 - Create Timeslots for the Venue ............................................................................................ 9
Step 5 - Assign a Home Venue to Teams .......................................................................................... 10
Step 6 - Create a Schedule ............................................................................................................... 11
Step 7 - View the Master Calendar or Reports .................................................................................. 12
Walkthrough Tutorial ......................................................................................................................... 13
Step 1 - Create a Division .................................................................................................................... 13
Step 2 - Create Teams.......................................................................................................................... 14
Step 3 - Create a Venue ....................................................................................................................... 15
  Optional: Enter Location Information ............................................................................................ 15
Step 4 - Create Timeslots .................................................................................................................. 16
Step 5 - Assign a Home Venue to Teams .......................................................................................... 17
Step 6 - Add People to the League .................................................................................................... 17
Step 7 - Schedule ............................................................................................................................... 18
Diamond Scheduler Manual ............................................................................................................. 20
File Menu ........................................................................................................................................ 20
  New ................................................................................................................................................ 20
  New Specialty Schedule ................................................................................................................... 21
  Open ............................................................................................................................................... 21
  Open Recent ................................................................................................................................ 22
  Import and Merge Another File ...................................................................................................... 22
  Save .............................................................................................................................................. 22
  Save As ........................................................................................................................................ 23
  Close ............................................................................................................................................ 23
Change League Type .......................................................................................................................... 23
DirectLink ....................................................................................................................................... 24
Import .............................................................................................................................................. 25
  Show Import Formats Window .................................................................................................... 26
  Pairings Import Window ............................................................................................................... 26
  Team Time Constraints Window .................................................................................................. 28
  Custom CSV Import Window ...................................................................................................... 29
Export ............................................................................................................................................... 31
  Export Window ............................................................................................................................. 31
  Export Person Information Window .............................................................................................. 34
  Export Division Pairings Window .................................................................................................. 34
  Export Options Window ................................................................................................................ 35
Exit .................................................................................................................................................... 36
Edit Menu ....................................................................................................................................... 37
  Copy .............................................................................................................................................. 37
  Paste ............................................................................................................................................ 37
Preferences ....................................................................................................................................... 37
  Open Calendar/Game List Without Data (faster navigation) ............................................................ 38
  Include Out-of-League Teams in Calendar Edit Panel ..................................................................... 38
  Hide Filtered Division Teams (slows performance) .......................................................................... 38
  Edit Default HTML Reports Header and Footer ........................................................................... 40
  Specify Data Directory .................................................................................................................. 41
  Clear Recent File History .............................................................................................................. 41
  Specify Default Timeslot Colors .................................................................................................... 42
  Customize Week Settings ................................................................................................................ 42
Date and Time Formats ................................................................. 43
Include Time in Calendar Month View ........................................ 44
Ignore Time and Travel Constraints for Special Requests .......... 45
Notify Me when I go Offline ......................................................... 45

Tools Menu ..................................................................................... 46
Number Games .................................................................................. 46
Quick Check Options .......................................................................... 48
Live Check Options ........................................................................... 50
Flip Home and Away for Scheduling Patterns ............................... 52
Generate All Across Divisions for Existing Divisions ..................... 53
Copy Division Games and Map to Remaining Open Timeslots ....... 53
Timeslot Calculator .......................................................................... 54
Move Entire Schedule ...................................................................... 57
Change Teams’ Divisions ................................................................ 58
Timeslot Division Changer .............................................................. 58
Lock All Schedules in this File ......................................................... 59
Lock All Scheduled Games in this File .......................................... 59
Unlock All Scheduled Games in this File ................................. 59
Unlock All Locked Games in this File .......................................... 59
Path Maps for Elimination Tournaments ...................................... 60
Create Placeholder League for Testing ........................................... 61

Reports Menu ................................................................................ 63
Division Schedules .......................................................................... 63
Team Schedules ............................................................................... 63
Venue Schedules ............................................................................ 64
Coach Contact Sheet ....................................................................... 64
Coaches with Multiple Teams ....................................................... 65
Team Games Per Week .................................................................... 66
Team Home Dates Available ........................................................ 67
Teams Not Playing by Date ............................................................ 68
Team Days Off Distribution ......................................................... 69
Teams Playing Fewer Matchups than Others .............................. 71
Team Special Requests ............................................................... 71
Team Time Constraints ............................................................... 72
Team Results Report ....................................................................... 73
Game Scores Reporting Sheet ...................................................... 75

View Menu .................................................................................... 78
Master Calendar ............................................................................. 78
Timeslot Detail Panel ....................................................................... 79
Filters Panel .................................................................................. 81
Master Calendar Toolbar .............................................................. 83
Calendar View Toolbar ............................................................... 84

Right-Click Options ....................................................................... 85
Select .......................................................................................... 85
Create ....................................................................................... 85
Reserve ..................................................................................... 86
Associate ................................................................................... 86
Convert ..................................................................................... 86
Split/Modify Timeslots ................................................................. 87
Modify Timeslots .......................................................................... 87
Filter by Division or Schedule .................................................... 88
Display Tooltip Information ....................................................... 89
Copy/Paste/Delete ......................................................................... 92
Switch and Flip ........................................................................... 93
Reschedule and Clear ............................................................... 93
Lock Games ............................................................................... 94
Add a Special Request Game: 148
Venues Tab: 150
People Tab: 153
Schedule Tab: 155
  Tournament Subscreen: 156
  League Subscreen: 159
Help Menu: 165
  Quickstart: 165
View Tutorials on the Web: 165
Support on the Web: 165
Register and Activate Diamond Scheduler: 166
Deactivate this Installation: 166
Check Status of Subscription: 166
Manage Account Online: 166
About Diamond Scheduler: 167
Index: 168
So, you’re impatient like me. If it needs instructions, it’s too complex, right? Well, no one ever became a champion without at least a little practice, so here are the basics of Diamond Scheduler.

**Step 1 - Create a Division**

Before you can have teams, you must create a division (you can think of it as a “level” if you don’t use the term “division” in your league).

To create your first division, click the Divisions tab. Then click the **New** button at the bottom of the screen.

There are two pieces of information that are required for a division: the name of the division or level and an abbreviation for the division or level. The abbreviation is used on calendar displays where space is limited. Creating short, unique abbreviations will make your calendars easier to read.
Step 2 - Create Teams

Now that you have a division, you can create the teams for the division on the Teams tab. The process is the same as creating a division. The name of the team and an abbreviation are required for each team.

```
<table>
<thead>
<tr>
<th>Division Name</th>
<th>Softball Seniors</th>
</tr>
</thead>
<tbody>
<tr>
<td>Team Name</td>
<td>Skylarks</td>
</tr>
<tr>
<td>Abbreviation</td>
<td>Sky</td>
</tr>
<tr>
<td>Custom Code</td>
<td></td>
</tr>
</tbody>
</table>
```

Step 3 - Create a Venue

Nothing different here. Click the New button on the Venues tab and enter the name of the venue and an abbreviation that is unique and suited for the crowded view of a calendar.

```
<table>
<thead>
<tr>
<th>Venue Name</th>
<th>Central Park</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abbreviation</td>
<td>CP</td>
</tr>
<tr>
<td>Custom Code</td>
<td></td>
</tr>
<tr>
<td>Address 1</td>
<td></td>
</tr>
</tbody>
</table>
```
Step 4 - Create Timeslots for the Venue

Next, specify the times that are available at the venue using the Timeslot Calendar screen. To access the Timeslot Calendar screen, click the Timeslots button on the Venues tab.

On the upper right side of the Timeslot Calendar screen, divisions are listed in the Divisions box. Before you create a timeslot, select the division(s) that can use the timeslots you are about to create. Don’t worry if they might need to change: you can always change the division assignment for timeslots later. However, if you get in the habit of identifying the division(s) for the about-to-be-created timeslot(s) before, it’s one less step.
Step 5 - Assign a Home Venue to Teams

So now you have your venue with timeslots that can be used by the division. There’s one more step to complete before scheduling this file: identifying which teams play home games at this venue.

In this case, we’ll say that all the teams in this division can play home games at this one venue. To indicate this:

1. Click the **Done** button on the right side of the Timeslot Calendar screen.
2. Click the **Edit** button for the venue.
3. Drag and drop all teams in the right box to the left box. You can also use the **Add All** button.
4. Click the **Done** button and you’re set to go!
Step 6 - Create a Schedule

To create a schedule based on the division, team, venue, and timeslots you have identified, access the Schedule tab and choose the type of schedule you wish to create. For this quick start, let’s just go with Round Robin. Based on the number of timeslots you have, the program will suggest a number of rounds to play.
Step 7 - View the Master Calendar or Reports

When the schedule is complete, you’ll be presented a screen similar to the following.

You can click the Master Calendar button or the Reports button to view your schedule.

If all you can stand to read is a quick start introduction to the software, then you’re done! Go for it and we wish you the best.

But if you need a little more hand holding, continue with the Walkthrough Tutorial to creating an entire schedule, while exploring some of the options and choices you can make while generating that schedule.

If you need a whole lot more detail, browse the Table of Contents or the Index to find information on a specific topic.
Before you begin scheduling, save yourself some trouble and make sure you have all the information you need. How many teams will there be? Who is the primary contact for each team? Are there specific dates where a team cannot play for some reason? Are the venues booked? What timeslots do you have available to work with as you schedule.

Once you have all the information, it’s time to schedule. For this walkthrough, we’ll use the example of a softball schedule with six teams: Kiwis, Quails, Finches, Robins, Parrots, and Skylarks. The division’s name is Majors Softball.

**Step 1 - Create a Division**

On the Divisions tab, click the **New** button at the bottom of the screen. The form will be enabled and you can enter the following information.

<table>
<thead>
<tr>
<th>Divisions</th>
<th>Teams</th>
<th>Venues</th>
<th>People</th>
</tr>
</thead>
<tbody>
<tr>
<td>Division Name</td>
<td>Majors Softball</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Abbreviation</td>
<td>MSsoft</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Custom Code</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Once you’ve entered the information, click the **Done** button or press the Enter key.
Step 2 - Create Teams

Create the six teams we need for our schedule on the Teams tab. As with the Divisions tab, click the New button at the bottom of the screen to begin entering information. Here are the teams we’ll be scheduling.

<table>
<thead>
<tr>
<th>Team Name</th>
<th>Team Abbreviation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kiwis</td>
<td>KIW</td>
</tr>
<tr>
<td>Quails</td>
<td>QUA</td>
</tr>
<tr>
<td>Finches</td>
<td>FIN</td>
</tr>
<tr>
<td>Robins</td>
<td>ROB</td>
</tr>
<tr>
<td>Parrots</td>
<td>PAR</td>
</tr>
<tr>
<td>Skylarks</td>
<td>SKY</td>
</tr>
</tbody>
</table>

**TIP:** As you create your team names, type in the name of the team and its abbreviation. Press the Enter key when you’re done. Then press the Space bar to create a new team. The data entry form will be enabled again. Team entry should go quickly.

Click the Done button once you’ve entered all the teams.
Step 3 - Create a Venue

Create a venue on the Venues tab where teams in this division can play. To keep this tutorial relatively simple, we’ll say that all teams play all their games at one venue. We’ll use “Central Park” with an abbreviation of “CP”.

Optional: Enter Location Information

If you are planning to limit travel distances for the division, you need to enter the location information for the venue. If all your teams will be playing at only one venue, this information is still useful for generating a map link for directions to the venue.

| Address 1 | 14 E. 60th St |
| City      | New York     |
| State     | NY           |
| Zip       | 10022        |

1. Enter the address information.
2. Click the Locate button on the upper right side of the screen to display a map.
3. Choose whether you prefer a Streets view or Satellite view.
4. Click the exact location of the venue. A red dot should appear where you clicked.
5. Click the Save Location button at the top of the map.
Once this information is entered, click the View button on the Venues tab to see the map, followed by the Copy button to copy the Google Maps link for the venue, which you might use in correspondence.

Step 4 - Create Timeslots

So, we have a venue where the teams can play, but we haven’t yet identified the specific times when the venue is available. Click the Timeslots button at the bottom of the Venues tab and the Timeslot Calendar screen will display.

Create the following timeslots at the venue using a template week with the following properties.

<table>
<thead>
<tr>
<th>Day</th>
<th>Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>Every weekday</td>
<td>5:30 PM</td>
</tr>
<tr>
<td>Saturday</td>
<td>3:00 PM, 4:30 PM, 6:00 PM</td>
</tr>
</tbody>
</table>

To accomplish this task, you’ll need to understand how to navigate around the Timeslot Calendar screen and how to create the actual timeslots. Refer to Navigating the Timeslot Calendar Screen for information on creating timeslots before moving on to step 5.
Step 5 - Assign a Home Venue to All Teams

So now you have your venue with timeslots that can be used by the Majors Softball division. Just a couple more steps to complete before scheduling this file. In this step, we need to identify which teams can play home games at this venue. In this case, we'll say that all the teams in this division can play home games at this one venue.

1. If you haven’t done so, click the Done button on the right side of the Timeslot Calendar screen to display the Venues tab again.
2. Click the Edit button for the venue.
3. Drag and drop all the teams in the box on the right side to the box on the left side to indicate they can all play home games at this venue.
4. Click the Done button and you’re set to go!

Step 6 - Add People to the League

If there are any coaches or players associated with more than one team, this step must be completed to ensure these people are not double-booked. Otherwise, this step can be skipped.

Access the People tab and click the New button. Complete the form as you would any of the previous forms.
Step 7 - Schedule

Okay, we’re now ready to schedule. However, you still have several decisions to make regarding the constraints you want to use. In addition, you may want to read up on the types of scheduling that are available. For this exercise, your assignment is the following:

A. Split the venues into two venues for the first week of play to use as practice times for the teams.
   1. Access the Timeslot Calendar screen by either navigating there from the Venues tab or selecting the Timeslot Calendar option from the View menu.
   2. In the Divisions box, select the check box next to Majors Softball.
   3. Select the Split for Practices check box and set the number of sub-venues to 2 per timeslot.
   4. Lasso the weekday timeslots for that week by holding down the Ctrl key (Command key on a Mac), holding down the left mouse button, and drawing a bounding box around the first five timeslots — all the weekday timeslots. This will select the timeslots.
   5. Click the Apply Above Properties button below the Divisions box. You will see that a copy of each of those timeslots is created and the name of the venue has been divided into Central Park [A] and Central Park [B]. These are our half venues for practice time.
   6. Repeat these steps for the first timeslot on Saturday.

B. Indicate that the Finches cannot play on Mondays because their coach works late that day.
   1. Access the Teams tab and choose the Finches in the Team Name field.
   2. Click the Time Constraints button at the bottom of the screen.
   3. Select the check box in the All Day column for Monday.
   4. Click the Save and Close button to save the selection and close the Time Constraints screen.

C. Create a week of practices for the teams.
   1. On the Schedule tab, click the (Edit) icon next to the Schedule field and change the name of the current schedule to “Practices”.
   2. On the Schedule tab, click the Practice button as the type of schedule you like to create.
   3. In the Number of Practices section, select the Practices per season option button and input 2 as the number of practices per season for this schedule.
   4. Click the Schedule Now button.
5. When the practices are done scheduling, click the Master Calendar button to see the schedule on a calendar layout. The Master Calendar is one of the most used reports since you can both visually assess what is happening with your league and make minor adjustments to the schedule.

D. Okay, so we’ve created a couple of practices for our teams at the beginning of the season. Let’s create the round robin schedule for the remainder of the season.

1. Create a new schedule for this division by clicking on the (Add Schedule) icon at the top right of the Schedule tab. Name the schedule “Games”.

2. Create a new schedule for this division by clicking on the (Add New Schedule) icon at the top right of the Schedule tab and name it “Games”.

3. This time, click the Round Robin button and you’ll be presented with a screen of options, which are detailed here. However, for this simple league, we don’t need to change any of the defaults, so click the Schedule Now button.

You should now have your completed schedule with the following:

1. Two practices for each team at the beginning of the season
2. The Finches are not scheduled on Mondays
3. Each team has 20 round robin games for the season (4 rounds of teams playing each other)

That should get you started. Once you have a schedule, explore the menu items that are available. Check out the Game List and explore the various reports you can create by filtering divisions, teams and venues.

Good job!
Lost and need some nitty-gritty details? Or just have a question about a particular option or setting? No problem! The topics in this manual cover every menu, every screen, and every field, providing you with all the information you need to become a master scheduler.

You can look up a specific screen or window using the table of contents or find an exact topic or field using the index.

**File Menu**

The File menu provides you with options used to manage your Diamond Scheduler files. A file can be seen as a set of divisions and their schedules.

For example, you may schedule a softball league using Diamond Scheduler for multiple years in a row and find it useful to have separate files for each year, such as “Little League 2015,” “Little League 2016,” “Little League 2017,” and so on. Or perhaps you schedule multiple types of sports, like a high school basketball league as well as a college soccer league. With Diamond Scheduler, it makes sense to keep those schedules in separate files.

The options in this menu allow you to manage these files, such as creating a new file, opening an existing file, or importing and exporting files. Some menu options can also be accessed using hot keys, which can save you time if you’re more of a keyboard person.

**New**

**How to Access:** Select File → New. You can also press the Ctrl+N hot key combo.

The New option is used to create a new Diamond Scheduler file. This option opens a new, blank schedule file.
New Specialty Schedule

How to Access: Select File → New Specialty Schedule.

Using the New Specialty Schedule option, you can create a "specialty schedule," or a new file for a schedule that will be integrated with third-party sports league management software systems, such as SportsEngine, LeagueAthletics, Sports Illustrated Play, or TeamSnap.

These types of schedules include special formatting and field names that help you identify where information specific to that management system should be entered. For example, if you create a schedule to integrate with LeagueAthletics, the **Custom Code** field on the Teams tab becomes the **LA Alias** field, with a prompt to enter the LeagueAthletics alias.

Example of specialty schedule field

Open

How to Access: Select File → Open. You can also press the Ctrl+O hot key combo.

Use the Open menu item much like you would in any other computer program. When you select this option, a file explorer window opens, and you can pick the schedule file you want to work with.
Open Recent

**How to Access:** Select File → Open Recent.

The Open Recent option provides you with a quick list of schedule files you’ve recently worked with. This is helpful to find that last file you were working on without going through the navigation you would do to locate a file with the Open menu item.

You can remove all the files in this list using the Clear Recent File History option.

Import and Merge Another File

**How to Access:** Select File → Import and Merge Another File.

This option allows you to merge one *.ds7 file with another *.ds7 file and import the new merged file to Diamond Scheduler.

For example, your co-scheduler, Bob, may be on one computer keeping information for the Eastern Division, and you may be working on another computer keeping information for the Western Division. You can use this option to merge the two files to create one schedule file using information for both divisions.

**Note:** This option does not resolve conflicts between files.

Save

**How to Access:** Select File → Save. You can also press the Ctrl+S (Command+S) hot key combo.

Save your file as often as you’d like to make sure you won’t lose any changes or information if something unexpected happens. You’re always prompted to save your file before exiting Diamond Scheduler, but it’s a good idea to save throughout the process, just in case.
Save As

**How to Access:** Select File → Save As. You can also press the Ctrl+Shift+S (Command+Shift+S) hot key combo.

The Save As option allows you to save your current file under another name. The file browser window will open, allowing you to navigate to your desired save location.

Close

**How to Access:** Select File → Close.

Selecting the Close option closes your current file, but leaves Diamond Scheduler open. As always, you will be prompted to save any changes you’ve made to your current file before closing it.

Change League Type

**How to Access:** Select File → Change League Type.

If you didn’t originally create a file as a Specialty Schedule, but now find that you need to, you can use the Change League Type option to change the schedule file to a format for a third-party sports league management software system, such as League Athletics, SportsEngine, Blue Sombrero, or many other formats. This will change some of the available fields to allow the file to be integrated with your league hosting site.

You can also change a specialty schedule to a Diamond Scheduler standard schedule by selecting the Diamond Scheduler Format option in the submenu.

For more information about specialty schedules, refer to New Specialty Schedule.
DirectLink

How to Access: Select File → DirectLink.

The DirectLink option allows you to directly connect Diamond Scheduler to a variety of third-party league host sites, such as TeamSnap and League Athletics.

Example of DirectLink log in screen

Once you select this option, you are presented with either a log-in screen to enter credentials for the host site or a menu, providing you with options for connecting your information between Diamond Scheduler and the host site.
Import

**How to Access:** Select File → Import.

Import a file to integrate the information with your current schedule file. For example, you can import your divisions, teams, and venues in CSV (comma-separated values) format to automatically add your league to Diamond Scheduler.

You can import CSV, JSON, other partner formats (such as those from third-party league management sites like LeagueApps and SportsEngine), or a Diamond Scheduler interchange file (*.DSX), which imports a Diamond Scheduler 6 file.

There are a few additional options for importing CSV files with more extensive settings, which are detailed in the following sections.
Show Import Formats Window

**How to Access:** Select File → Import → CSV → Show Import Formats.

If you need to import a CSV file, Diamond Scheduler includes samples of the correct formatting for each type of import (divisions, teams, venues, and so on).

Click the button at the top of the window for the type of information you're importing. You can then click the **Copy Sample Line to Clipboard** button to paste the information into your CSV file.

Pairings Import Window

**How to Access:** Select File → Import → CSV → Custom Pairings.

If you have pairings from a previous schedule that you'd like to use in your current schedule, you can use the Pairings Import window to create a template for importing that information.
Select the information you want to import into Diamond Scheduler in the Items in File section. As you add, you'll see the items display in the Order of Items in File box to the right of the screen. You can rearrange the order you want the information to show in by simply dragging and dropping the items into order.

In addition, the items will display in the Sample File Content section, which will show you examples of how the information in your import file should look. Click the Copy Sample button to copy the text so you can paste it into your file and use it as a template.

When you're done, click the Import button and select the file to import.
What's on this Screen

- **Pairings for Which Schedule.** Choose the schedule you want to use the imported pairings for.
- **Automatically Create Across-division Divisions, if Needed.** If there are pairings for teams that aren't in the same division, Diamond Scheduler will automatically create across-division divisions for those pairings.
- **Lock Currently Scheduled Games and use the Imported Pairings for Additional Games.** If you already have scheduled games, select this check box to lock those games and only use the pairings in additional games.
- **Balance home and away games.** Selecting this option will help balance out the number of home and away games that are scheduled using the pairings in your import file.
- **Contains All Games.** Select this option button if the pairings import file includes all games for the season.
- **Contains 1 Round.** Select this option button if the pairings import file includes only enough games for one round. Diamond Scheduler will automatically create games for additional rounds as indicated on the Schedule tab.

Team Time Constraints Window

**How to Access:** Select File → Import → CSV → Team Time Constraints.

Importing team time constraints requires a very specific CSV format. Diamond Scheduler can automatically create the template for you that includes information for the teams in your file, including the team name, team ID, and specially formatted requirements.
To create the template, click the **Create Template** button. A file is created, and the browser file on your computer opens so you can save the template export where you'd like.

You can also import a file with time constraint information by clicking the **Import Time Constraints** button. Your computer's browser file window opens so you can select the file to import.

### Custom CSV Import Window

**How to Access**: Select File → Import → CSV → Custom CSV.

If you have any information that you'd like to import to your schedule file, you can use the Custom CSV Import window to create a template for importing that information.
Select the information you want to import into Diamond Scheduler in the Items Included in CSV File section. As you add, you'll see the items display in the Order of Items box to the right of the screen. You can rearrange the order you want the information to show in by simply dragging and dropping the items into order.

In addition, the items will display in the Sample File Content section, which will show you examples of how the information in your import file should look. Click the Copy Sample button to copy the text so you can paste it into your file and use it as a template.

When you're done, click the Import button and select the file to import.
You can export a variety of information from your schedule file in a number of formats using the Export option. For example, you can export a list of your teams as a CSV file or your master calendar as a Google iCal file. These files can be helpful for getting print copies of schedules or rosters to refer to on the field or to post in a Google calendar.

Some options when exporting a schedule simply open your computer browser window so you can save the export file. Others prompt you with a window to make a few easy schedule selections or simply provide more information on what you're exporting. However, there are a number of options for exporting files that include more extensive settings, which are detailed in the following sections.

**Export Window**

**How to Access:** Select File → Export → HTML or CSV. Then select the Division Schedules, Team Schedules, or Venue Schedules submenu option.

This window can also be accessed by selecting the Reports menu, followed by the Division Schedules, Team Schedules, or Venue Schedules submenu option. Then select either HTML or CSV.

The Export window is used to customize the information that is exported for a schedule in an HTML or CSV file. The name of this window changes based on the type of export you select. For example, it is the Export Divisions window when you select the Division Schedules option.

You can export information for all schedules or for a specific division, team, or venue using the field at the top of the window. Select options to customize what's included in the exported file, then click the Export button to export the file to your computer.
The options on this screen vary based on the type of export you're creating or report you are running.

- **Use Default HTML Header.** Add the default HTML header you defined on the HTML Header window to the file.
  
  **Note:** This option can display as the **Use Default Header** check box on some versions of the Export window.

- **Export Only Open Timeslots.** Include only open (unscheduled) timeslots in the schedule export.

- **Export Only Unscheduled Timeslots.** Include only open (unscheduled) timeslots in the schedule export.
• **Export to Separate File for each [Division/Team/Venue]**. If you export all schedules, you can easily make each its own file by selecting this option.
  • **Do not include division name in file name**. Export team schedules without including the division names.

• **Include Game Numbers**. Include game numbers in the export. You can number your games using the **Number Games** option.

• **Include End Times**. Include the end times for the games in the schedule. This option is required to re-import schedules to a different file.

• **Include Open Timeslots**. Include open timeslots in the schedule for the venue.

• **Include Division Names (Required to re-import)**. Include the division names for the teams in a schedule. This option is required if you want to re-import the information.

• **Include Unscheduled Timeslots**. Include timeslots that have not been scheduled in the export.

• **Include Across-Division Games**. Include games for across-divisions in the export.

• **Include Time Since Last Game**. Include the number of days a team has had off since their last game.

• **Include Coach Contact Information (HTML only)**. Include the contact information for each coach, such as the coach’s phone number and email address. This information can only be included when exporting to HTML.
  • **Include Phone Numbers**. Include the coaches’ phone numbers.
  • **Include Email Addresses**. Include the coaches’ email addresses.

• **Include Venue Addresses (HTML only)**. Include the addresses of the venues in the schedules. This information can only be included when exporting to HTML.

• **Include Special Events**. Include special event games in the schedule.

• **Confine to specific date range**. Export only games within a specific date range. Click the **Specify dates** button to open a calendar where you can pick the dates to export.
Export Person Information Window

**How to Access:** Select File → Export → HTML or CSV. Then select the Persons submenu option.

This window is used to export information about the people entered on the People tab to an HTML or CSV file. Select the items to include, such as addresses, email addresses, phone numbers, or notes, and then click the Export button to export the file to your computer.

Export Division Pairings Window

**How to Access:** Select File → Export → CSV → Pairings.

If you've already created your schedules, you can export the pairings that were created using this window. Simply select the division and schedule to export, and then select whichever pieces of information you want included in the file.
Export Options Window

How to Access: Select File → Export → CSV → Custom Schedule Export.

You can make an export file of just about anything using the Custom Schedule Export option. You'll get the Export Options window, which lets you pick, choose, select — however you want — a bunch of different information in your schedule file to add to an export.
As you select information, you'll see those items display in the Order of Items box. You can rearrange the order they'll be exported in by simply dragging and dropping the items into order. When you're done, click the **Export** button and save your file to your desired location on your computer.

**Exit**

**How to Access:** Select File → Exit.

Close Diamond Scheduler by selecting the Exit option. If you have a schedule file currently open and unsaved, you'll be prompted to save before the system closes.
Edit Menu

The Edit menu includes options for copying and pasting information, as well as a Preferences submenu, which includes some ways you can personalize how your schedule file looks and functions.

Copy

How to Access: Select Edit → Copy. You can also press the Ctrl+C (Command+C) hot key combo.

Chances are, you know how to copy information, and you most likely even know the keyboard shortcut for it. But in case you like to do things formally, you can use the Copy option in this menu.

Paste

How to Access: Select Edit → Paste. You can also press the Ctrl+V (Command+V) hot key combo.

Once you’ve copied information, you can paste it using the Paste option or the Ctrl+V hot key.

Preferences

How to Access: Select Edit → Preferences.

The Preferences option includes a submenu of functions that can be used for changing the format of your calendars and times, as well as few settings that can affect performance.

The following options are available in the Preferences submenu.
**Open Calendar/Game List Without Data (faster navigation)**

**How to Access:** Select Edit → Preferences → Open Calendar/Game List Without Data (faster navigation).

This option can save you some time when opening the Master Calendar screen or Game List if you have a really big league. For example, if you have 1,000 games, it can take a while to render the Master Calendar, which can slow down the program and leave you hanging. However, if this option is enabled, you can access the Master Calendar screen without loading your data. You can then filter by only the information you want to see, making navigation quicker.

**Include Out-of-League Teams in Calendar Edit Panel**

**How to Access:** Select Edit → Preferences → Include Out-of-League Teams in Calendar Edit Panel.

Select this option to indicate that you want out-of-league teams included in the choices for the Visitor field and Home field on the Timeslot Detail panel.

**Hide Filtered Division Teams (slows performance)**

**How to Access:** Select Edit → Preferences → Hide Filtered Division Teams (slows performance).

You can select this option to automatically hide teams that are not included in divisions selected on the Master Calendar screen. For example, the following image displays how the filters on the Master Calendar screen display without this option enabled. Notice that even though only the East League division is selected in the Division section, teams from both the East League and West League are displaying in the Team section.
Without the Hide Filtered Division Teams option enabled

While enabling this option can slow performance of the system, you may find it easier to navigate the Master Calendar screen with this option activated, as it cleans up the available filters based on the division selected. The following image is how the filters display with the same division selection when this option is enabled. Notice now that only teams in the East League are shown when the East League filter is selected.
With the Hide Filtered Division Teams option enabled

Edit Default HTML Reports Header and Footer

How to Access: Select Edit → Preferences → Edit Default HTML Reports Header and Footer.

You can edit the header or footer of exported HTML reports using the Edit Default HTML Reports Header and Footer option. The following window displays, where you can change the default title for HTML reports and even include your own logo in the title.
To include a logo, click the **Choose logo** button. Your computer’s file browser will display and you can navigate to and choose the file you want to use. If you don’t want a logo at all, simply select the **Do not include logo** check box.

This option is great for customizing the look of your exported reports, helping you add authority and team spirit to your printed or exported schedules or rosters.

### Specify Data Directory

**How to Access:** Select Edit → Preferences → Specify Data Directory.

If you need to change the location where your schedule files are kept, you can do this by selecting the Specify Data Directory option. Your computer’s file browser will display, and you can select the folder or location where data for Diamond Scheduler should be stored. Once you’ve selected the new directory, a message window displays, confirming the new location.

### Clear Recent File History

**How to Access:** Select Edit → Preferences → Clear Recent File History.

So maybe you use your Open Recent option in the File menu all the time to switch between a few frequently used files. But maybe you also created some test files and now your list is cluttered with files you don’t need. Simply click the Clear Recent File History option to remove the files in the Open Recent list (don’t worry – the files don’t get deleted!) and start over with a new list.
Specify Default Timeslot Colors

How to Access: Select Edit → Preferences → Specify Default Timeslot Colors.

Love the color-coding on the Master Calendar screen and Timeslot Calendar screen, but hate the colors? Feel free to pick your own colors using the Specify Default Timeslot Colors option. Click this option to access the Default Timeslot Colors window, where you can pick colors for practice timeslots, unassigned timeslots, multi-division timeslots, and event timeslots.

![Default Timeslot Colors](image)

Simply click the (Color Palette) icon next to a timeslot to choose from 228 different colors. Click the Save button to save your choices.

Customize Week Settings

How to Access: Select Edit → Preferences → Customize Week Settings. Or click the (Configure days that are displayed on the calendar) icon on the Calendar View Options.

You can customize how the calendars on the Master Calendar screen and Timeslot Calendar screen display using this option.
When you select Customize Week Settings, you’re presented with the following window, which includes options for which day of the week the calendar views should begin on and which days of the week should display on the calendar. For example, if your league doesn’t play on weekends, you can hide Sundays and Saturdays by selecting the **Sunday** and **Saturday** check boxes in the **Hide days of week** column, effectively expanding the real estate of your weekday slots on screens like the **Master Calendar screen**.

![Days of Week Settings](image)

You can also choose a beginning hour for the Day and Week views on the calendars using the **First Display Hour** field. For example, if your league does not schedule games earlier than noon, you can choose to start the calendar views at noon, minimizing the space needed to show the empty hours before then.

**Date and Time Formats**

**How to Access:** Select Edit → Preferences → Date and Time Formats.

Clicking the Date and Time Formats option opens the Preferred Date and Time Formats window, which you can use to customize how you want dates and times throughout the system to display. Select the option button corresponding to your desired format and then click the **Save** button.
Include Time in Calendar Month View

**How to Access:** Select Edit → Preferences → Include Time in Calendar Month View.

This option can be selected to display game times on the Month view on the Master Calendar screen. When this option is selected, the time of the game displays before the game description, allowing you to quickly determine when games are at a glance.
Ignore Time and Travel Constraints for Special Requests

**How to Access:** Select Edit → Preferences → Ignore Time and Travel Constraints for Special Requests.

When this option is enabled, all time and travel constraints defined on the Teams tab are ignored whenever special request games are created.

Notify Me when I go Offline

**How to Access:** Select Edit → Preferences → Notify Me when I go Offline.

If the Diamond Scheduler system is disconnected from an Internet connection, you can be notified if this option is enabled.

"Disconnected" displays in red in the corner of any screen when your system is disconnected. (This notification pops up over the "Registered" label in the top right corner.)

Once your system is reconnected to a network, "Connected" displays in green, letting you know that Diamond Scheduler is back online.
Tools Menu

The Tools menu is chock-full of options that allow you to quickly perform a variety of actions on your schedule file, such as running a check for overlapping games, moving your entire schedule, or changing the divisions for multiple teams at once. Think of this menu as your toolbox for saving you time when you need something big done in a snap.

Number Games

How to Access: Select Tools → Number Games.

You can choose to number your games, which may help you more easily refer to them. For example, by choosing this option, the first game of the season – let’s say it’s Quails versus Parrots – displays as the following graphic in Week view.

*Example of numbered games on the Master Calendar screen*

When you select this option, the Assign Game Numbers window displays, which provides you with a number of options to specify how games should be numbered. When you've finished defining your options, click the Number Games button to number or renumber your games.
What's on this Screen

Note: To view all of the options on this window, click the Advanced Options button.

- **Keep Any Existing Numbers.** Keep the numbers for any games that have already been numbered. Numbers will only be added to games that don’t have numbers.

- **Include Practices when Numbering.** Include practice games when numbering.

- **Numbering Options.** Select one of the following options to indicate how games should be assigned numbers.
  
  - **Number by Date Across All Divisions.** Number all games in order of schedule with no regard to divisions. Therefore, you might have a “Game 1” for one division, but the first game in the other division could be “Game 2”. All games across all divisions will have unique numbers.

  - **Number by Date Grouped by Division.** Number all games in a division before numbering games in subsequent divisions. For example, if you have 30 games in Division 1, these games will be numbered 1-30, and the first game in your second division will be “Game 31”. All games across all divisions will have unique numbers.
• **Number Uniquely within Divisions.** Number all games by division. For example, the first game for your first division will be “Game 1,” but your first game for your second division will also be “Game 1”. Games across divisions will repeat the same numbers.

• **Only Locked or Unlocked Games.** You can choose whether only locked games or unlocked games should be numbered. Below this option, select the appropriate option button.

• **Limit to Specific Schedules.** Limit numbering to only games within a specific schedule. When you select this check box, your divisions display in the box below, and you can click which divisions should be numbered.

  **TIP:** Hold the Ctrl key (or Command key on a Mac) and click to select multiple divisions.

• **Remove All Existing Game Numbers.** Remove all existing game numbers before changing any game numbers. You’ll get a confirmation message to make sure you want to remove the numbers, just in case you accidentally click this button.

---

**Quick Check Options**

**How to Access:** Select the Tools menu. Then select an option that begins with "Quick Check".

The Quick Check options let you quickly scan your schedule to check for a variety of conflicts, rather than needing to manually review the whole schedule yourself. When you run a quick check, a window similar to the following displays, including information such as the conflicting team, division, or coach and the date and time of the conflict.
Example of conflict window for coach conflicts

The exact information on the window varies, but each tells you what you need to know to locate and correct the conflict. You can also add your own notes directly into the window and even copy the contents of the window by clicking the Copy to Clipboard button.

The following Quick Check options are available.

- **Quick Check for Timeslot Conflicts.** A timeslot conflict occurs when a team is scheduled for two or more games at the same time. For instance, it's a conflict if the Finches are scheduled to play the Robins on Sunday from 10:00 am to 11:00 am, and are also scheduled to play the Skylarks on Sunday for 10:00 am to 11:00 am.

- **Quick Check for Overlapping Games for Teams.** An overlapping game conflict occurs when a team is scheduled for a game that starts before a game they are also in ends. For example, there is a conflict when the Robins are scheduled for 10:00 am to 11:00 am, and are also scheduled for a 10:30 am to 11:30 am game.

- **Quick Check for Multiple Games for Teams.** This option can be used to check for instances where a team is scheduled to play two or more games on the same day.

- **Quick Check for Coach Conflicts.** Coaches with multiple games scheduled at the same time are highlighted in orange on the Master
Calendar screen or the Timeslot Calendar screen. However, you can quickly check for any coach conflicts by selecting this option.

- **Quick Check for Time Constraint Conflicts.** You can check for time constraint conflicts, such as when a team that is marked to not be able to play after 4:00 pm on Mondays is scheduled for a game on Monday at 5:00 pm.

## Live Check Options

**How to Access:** Select the Tools menu. Then select an option that begins with "Live Check".

The Live Check options provide the same conflict checks as the Quick Check options, but do so automatically rather than manually. For example, if you schedule a game that creates a conflict, you’re instantly notified as soon as the conflict occurs, allowing you to acknowledge or fix the problem right away. When a conflict occurs, a window similar to the following displays, including information such as the conflicting team, division, or coach and the date and time of the conflict.

![Example of conflict window for coach conflicts](image)
The exact information on the window varies, but each tells you what you need to know to locate and correct the conflict. You can also add your own notes directly into the window and even copy the contents of the window by clicking the Copy to Clipboard button.

Enabling this option also creates a notification on the Master Calendar screen and Timeslot Calendar screen. Conflicts are automatically highlighted in orange with a ⚠️ (Caution) icon. You can also display only timeslots that have conflicts on the Master Calendar screen by selecting the Conflicts check box in the Calendar View toolbar.

Note that selecting a Live Check option activates Diamond Scheduler to constantly scan for timeslot conflicts, which can slow the overall performance of the system. Therefore, it may be best to only enable these options when actively creating schedules.

The following Live Check options are available.

- **Live Check for Timeslot Conflicts.** Enabling this option automatically notifies you when a timeslot conflict is scheduled. A timeslot conflict occurs when a team is scheduled for two or more games at the same time. For instance, it's a conflict if the Finches are scheduled to play the Robins on
Sunday from 10:00 am to 11:00 am, and are also scheduled to play the Skylarks on Sunday for 10:00 am to 11:00 am.

- **Live Check for Overlapping Games for Teams.** When you select this option, Diamond Scheduler automatically scans for games in which a team is scheduled for an overlapping time. For example, if the Robins are scheduled for 10:00 am to 11:00 am, and then are scheduled for a 10:30 am to 11:30 am game, a notification instantly displays when the second game is scheduled.

- **Live Check for Multiple Games for Teams.** This option automatically notifies you when multiple games are scheduled for the same team on the same day. For example, if a Finches game is already scheduled on Tuesday, and another Finches game gets scheduled that same day, you’ll get an instant notification.

- **Live Check for Coach Conflicts.** Enabling this option automatically notifies you when a coach who leads multiple teams is scheduled to be in multiple places at the same time or to be coaching multiple teams at the same time.

- **Live Check for Time Constraint Conflicts.** If a time constraint conflict occurs, such as when a team that is marked to not be able to play after 4:00 pm on Mondays is scheduled for a game on Monday at 5:00 pm, you’ll get an automatic notification if this option is enabled.

### Flip Home and Away for Scheduling Patterns

**How to Access:** Select Tools → Flip Home and Away for Scheduling Patterns.

This option can be used to flip home and away teams for venues in a rotation matrix. For example, suppose you have a base rotation of teams 1 v 10, 2 v 9, 3 v 8, 4 v 7, and 5 v 6. When you select the Flip Home and Away for Scheduling Patterns, the rotation becomes 10 v 1, 9 v 2, 8 v 3, 7 v 4, and 6 v 5.

This option is useful in situations where each team has different venues where they can play home games, and "mixing up" the home and away teams for the venues might help correct a schedule.
**Generate All Across Divisions for Existing Divisions**

**How to Access:** Select Tools → Generate All Across Divisions for Existing Divisions.

Select this option to automatically create across-divisions divisions (that is – divisions that combine two divisions) for all existing divisions. Across-divisions are created for each existing division combination.

For example, suppose you have Division 1, Division 2, and Division 3. When you select this option, three across-divisions are created combining Divisions 1 and 2, Divisions 1 and 3, and Divisions 2 and 3. This shortcut is useful if you are creating across-division games.

**Copy Division Games and Map to Remaining Open Timeslots**

**How to Access:** Select Tools → Copy Division Games and Map to Remaining Open Timeslots.

You can quickly copy all scheduled games and copy them into open timeslots for the remainder of the season using this option. When you click this option, the Clone Games to Empty Timeslots window displays, where you can pick which division’s games to copy, and whether the games should be copied until all open timeslots are used or if the games should only be copied a certain number of times.
If you select the **Copy Template for Certain Number of Times** option button, an additional field displays where you can define how many rounds the schedule should be copied for.

### Timeslot Calculator

**How to Access:** Select Tools → Timeslot Calculator.

The Timeslot Calculator is a useful tool for helping you figure out ahead of time how many timeslots you'll need to create in your schedule to accommodate a certain type of schedule, number of teams, and number of games. When you select this option, the Timeslot Calculator window displays, and prompts you first for the type of schedule you will be creating.
Select the schedule type to access additional calculator options for each. A window similar to the following displays.

![Example of additional options window for Timeslot Calculator](image_url)
For each scheduling option, you'll need to specify the number of teams you'll be including in the schedule. When you increase or decrease the teams, the timeslot calculation in the **Timeslots** column automatically adjusts for the new numbers.

If you picked a League (Round Robin) type schedule, you can also specify how many maximum possible rounds can be scheduled or you can define a specific number of rounds that should occur. You can also toggle between showing the number of timeslots needed and showing your current timeslot count by venue by clicking the **Show Timeslots Needed** button (or the **Show Timeslot Detail by Venue** button, depending on your current view).

You can also click the **Division Distribution** button on the Timeslot Calculator window to see how many timeslots have been used or are available for each of your divisions, including ones that are unassigned. To go back to the Type of Schedule subscreen, simply click the **Menu** button.

<table>
<thead>
<tr>
<th>Division Assignment</th>
<th>Total Timeslots</th>
<th>Used</th>
<th>Available</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unassigned</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>East League</td>
<td>41</td>
<td>40</td>
<td>1</td>
</tr>
<tr>
<td>West League</td>
<td>41</td>
<td>39</td>
<td>2</td>
</tr>
</tbody>
</table>
Move Entire Schedule

**How to Access:** Select Tools → Move Entire Schedule.

You can move the start date for your entire schedule at one time using the Move Entire Schedule option, which allows you to shift your schedule to a specific date or by a number of days, hours, and minutes.

Select the date or define the number of days/hours/minutes to shift your schedule by. Then select the schedule you want to move in the field below the calendar. **All Schedules** is automatically selected for you, but you can pick a specific schedule to move. Click the **OK** button when you’re done to move your schedule.
Change Teams' Divisions

**How to Access:** Select Tools → Change Teams' Divisions.

This option is available to let you switch a team to a different division, even if the team has scheduled games or practices. However, it is strongly advised that you move a team using the Move Team to Different Division window on the Teams tab (which can only be used if the team is not scheduled for any games or practices), as a number of conflicts can occur otherwise. If you still wish to use this option, it is also advised that you save your file using a different file name before moving a team to have a backup.

Timeslot Division Changer

**How to Access:** Select Tools → Timeslot Division Changer.

Using the Timeslot Division Changer window, you can quickly switch all the timeslots for a certain venue to a certain division’s timeslots. For example, suppose all your timeslots for the East Diamond venue are currently assigned to the East League, but you want to change them to the West League. On this window, simply click East Diamond in the left box and West League in the right box, and click the Change button.
**Lock All Schedules in this File**

**How to Access:** Select Tools → Lock All Schedules in this File.

Click the Lock All Schedules in this File option to — you guessed it — lock all the currently created schedules in the current file. You’ll get a confirmation prompt before the schedules are locked.

**Lock All Scheduled Games in this File**

**How to Access:** Select Tools → Lock All Scheduled Games in this File.

Select this option to lock all games that have already been scheduled in the current file. You’ll get a confirmation prompt before the games are locked.

**Unlock All Schedules in this File leaving Timeslots**

**How to Access:** Select Tools → Unlock All Schedules in this File leaving Timeslots.

Using this option, you can unlock all locked schedules, but leave any existing timeslots on your calendar, allowing you to reschedule the timeslots without having to create the timeslots again. You’ll get a confirmation prompt before the schedules are unlocked and deleted.

**Unlock All Locked Games in this File**

**How to Access:** Select Tools → Unlock All Locked Games in this File.

Select this option to unlock all locked games that have already been scheduled in the current file. As usual, you’ll get a prompt to make sure you’re certain you want to unlock and delete the games.
**Path Maps for Elimination Tournaments**

**How to Access:** Select Tools → Path Maps for Elimination Tournaments.

Diamond Scheduler is equipped with a variety of printable path maps (commonly known as “brackets”) that you can use for planning and tracking elimination style tournaments. Clicking the Path Maps for Elimination Tournaments option brings you to the following screen, where you can choose from over 50 bracket options.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>4 Teams</td>
<td>4 Teams</td>
<td>4 Teams</td>
<td>4 Teams</td>
</tr>
<tr>
<td>5 Teams</td>
<td>5 Teams</td>
<td>5 Teams</td>
<td>5 Teams</td>
</tr>
<tr>
<td>6 Teams</td>
<td>6 Teams</td>
<td>6 Teams</td>
<td>6 Teams</td>
</tr>
<tr>
<td>7 Teams</td>
<td>7 Teams</td>
<td>7 Teams</td>
<td>7 Teams</td>
</tr>
<tr>
<td>8 Teams</td>
<td>8 Teams</td>
<td>8 Teams</td>
<td>8 Teams</td>
</tr>
<tr>
<td>9 Teams</td>
<td>9 Teams</td>
<td>9 Teams</td>
<td>9 Teams</td>
</tr>
<tr>
<td>10 Teams</td>
<td>10 Teams</td>
<td>10 Teams</td>
<td>10 Teams</td>
</tr>
<tr>
<td>11 Teams</td>
<td>11 Teams</td>
<td>11 Teams</td>
<td>11 Teams</td>
</tr>
<tr>
<td>12 Teams</td>
<td>12 Teams</td>
<td>12 Teams</td>
<td>12 Teams</td>
</tr>
<tr>
<td>13 Teams</td>
<td>13 Teams</td>
<td>13 Teams</td>
<td>13 Teams</td>
</tr>
<tr>
<td>14 Teams</td>
<td>14 Teams</td>
<td>14 Teams</td>
<td>14 Teams</td>
</tr>
<tr>
<td>15 Teams</td>
<td>15 Teams</td>
<td>15 Teams</td>
<td>15 Teams</td>
</tr>
<tr>
<td>16 Teams</td>
<td>16 Teams</td>
<td>16 Teams</td>
<td>16 Teams</td>
</tr>
</tbody>
</table>

Brackets are available for four different types of elimination tournaments, detailed below.

- **Single Elimination Best-Worst.** This style tournament eliminates teams upon their first loss, similar to the NCAA basketball tournament. Seedings are based on the best team playing the worst team.

- **Single Elimination Balanced.** This style tournament also eliminates teams upon their first loss. However, seedings are spread between more similarly matched teams to produce a tournament where underdogs are more likely to have a chance at winning.
• **Double Elimination Best-Worst.** In this style tournament, teams are not eliminated until they have lost two games. Seedings are based on the best team playing the worst team.

• **Double Elimination Balanced.** In a Double Elimination Balanced style tournament, teams are not eliminated until they have lost two games. However, seedings are spread between more similarly matched teams to produce a tournament where underdogs are more likely to have a chance at winning.

To print a bracket, simply click the number of teams in your tournament under the style of tournament being played. A separate screen with the bracket displays, and you can print the bracket from a web browser tab by clicking the View/Print from Web button.

---

**Example of path map**

**Create Placeholder League for Testing**

**How to Access:** Select Tools → Create Placeholder League for Testing.

If you’re new to Diamond Scheduler and want to explore the system without having to spend the time entering a bunch of data, or even if you’re more of a pro
and just want to test a few things without messing up your current data, you can create a placeholder league. A placeholder league automatically creates generic divisions, teams, venues, coaches, and players that you can then manipulate as you would your own actual data, but without the risk of testing features on your own schedules.

Select this option to display the Create Placeholder League window. Simply enter the desired number of divisions, teams, venues, coaches, and players (most likely you’ll want numbers similar to your own league), and click the Create button. Diamond Scheduler then does all the tedious data entry for you!
The Reports menu contains options that provide you with useful summaries of your league information. For example, you can quickly generate a list of coaches’ names, phone numbers, and email addresses without needing to access each coach’s record in the system and writing down the information. Because who has time for that?

The reports available in this menu can be helpful for providing copies of information to key league people, like coaches or umpires, as well as statistics or lists that would be difficult to generate by going through all your data yourself.

**Division Schedules**

**How to Access:** Select Reports → Division Schedules. Then select either the HTML or CSV submenu option.

Run the Division Schedules report to create an HTML or CSV version of your division schedules. There are several options on the Export window that you can use to customize what’s included in your report. For example, select the Include Game Numbers check box to list the games in your schedule by game number. Different options are available on this window depending on whether you choose to export to HTML or CSV, and each option is detailed in the Export window topic.

**Team Schedules**

**How to Access:** Select Reports → Team Schedules. Then select either the HTML or CSV submenu option.

You can export schedules for your individual teams, in either HTML or CSV format, using the Team Schedules option. Selecting this option displays the Export window, which includes a number of check boxes that can be selected or left blank to customize the information your report contains. Different options are
Venue Schedules

**How to Access:** Select Reports → Venue Schedules. Then select either the HTML or CSV submenu option.

Run the Venue Schedules report to create an HTML or CSV version of your schedules by venue. There are several options on the Export window that you can use to customize what’s included in your report. For example, select the Include Open Timeslots check box to include timeslots that don’t have games scheduled in your report. Different options are available on this window depending on whether you choose to export to HTML or CSV, and each option is detailed on the Export window topic.

Coach Contact Sheet

**How to Access:** Select Reports → Coach Contact Sheet.

The Coach Contact Sheet report is an easy way to generate a list of contact information, such as phone numbers and email addresses, of each coach on your roster. When you select this option, the Coach Contacts window displays with a number of fields that can be used to customize the information that’s included in the report.
You can name the report, select whether to include coaches for all divisions and teams or a specific division and team, and choose whether to export the information in HTML or CSV format.

**Coaches with Multiple Teams**

**How to Access:** Select Reports → Coaches with Multiple Teams.

The Coaches with Multiple Teams report is an in-system report (as opposed to exportable) that quickly shows you which coaches are assigned to multiple teams. Though there are plenty of options within Diamond Scheduler to help prevent coaches from being double-booked, this report can help you keep in mind which coaches might need a little more slack in their schedules.
While the report can’t be directly exported, you can add your own notes directly into the window and copy the contents of the window by clicking the *Copy to Clipboard* button.

**Team Games Per Week**

**How to Access:** Select Reports → Team Games Per Week.

You can get a quick count of how many games each team is scheduled for each week using the Team Games per Week report. To generate the list of games, select the division and the schedule to display (you can also select to include all divisions and all schedules in the report). Then click the *Refresh Frequencies* button.
The report is divided by division, and the weeks are numbered as the columns of the report. The report also includes a **Total** column to display the total number of games each team plays and a **Byes** column to display the number of bye weeks each team has.

There are some handy options for collapsing and expanding only the information you want to or don’t want to see. You can collapse or expand a certain division by clicking the ▼ (Grey Arrow) icon next to the division, or you can expand or collapse all the listed divisions by clicking the ▶ (Plus Sign) icon or ▼ (Minus Sign) icon at the bottom of the window.

**Team Home Dates Available**

**How to Access:** Select Reports → Team Home Dates Available.

You can run the Team Home Dates Available report to quickly generate a list of all available home timeslots for a certain division or all divisions. To generate the report, select the division on the Available Home Timeslots window and click the **View** button.
The Home Timeslot Analysis window displays and lists details for the available timeslots, including the venue, the teams that share the timeslot, and the number of timeslots reserved for the division.

**Note:** This report will not include timeslots that are already scheduled and used by divisions.

**Teams Not Playing by Date**

**How to Access:** Select Reports → Teams Not Playing by Date.

The Teams Not Playing by Date report can be used to export a list of teams not playing on certain days of the week. For example, you may have a set of teams that still need to play each other because their game got rained out. You can use this report to quickly find a date when both teams are available.
Simply select whether to include all divisions or a certain division, which days of the week to include on the report, and whether to export the report in HTML or CSV format.

**Team Days Off Distribution**

**How to Access:** Select Reports → Team Days Off Distribution.

The Team Days Off Distribution report is useful for quickly identifying how many times a team has fewer or greater than a certain number of days off. For instance, you may have a little league that requires teams have a certain number of days off before playing again. Using this option, you can enter the time off
requirements in the fields at the bottom of the window, select the divisions and schedules to show, and click the \(\text{(Refresh)}\) button to generate the list.

<table>
<thead>
<tr>
<th>Div</th>
<th>Team</th>
<th>Fewer Than</th>
<th>Greater Than</th>
</tr>
</thead>
<tbody>
<tr>
<td>East</td>
<td>Bluejays</td>
<td>6</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td>Cardinals</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Finches</td>
<td>2</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Robins</td>
<td>4</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td>Skylarks</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>Wes</td>
<td>Doves</td>
<td>6</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Hummingbirds</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>Magpies</td>
<td>4</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>Ravens</td>
<td>4</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>Swallows</td>
<td>3</td>
<td>3</td>
</tr>
</tbody>
</table>

Hover mouse over frequencies to see dates involved

- Fewer than 2 days off
- Greater than 4 days off

The number of times a team meets the criteria displays in the **Fewer Than** or **Greater Than** column. For example, if you enter “Fewer than 2 days off” and 1 displays in the **Fewer Than** column for a team, there is one instance where the
team has fewer than two days off. You can then hover your mouse over the calendar icon next to the number to see exactly which dates are included in this count.

**Teams Playing Fewer Matchups than Others**

**How to Access:** Select Reports → Teams Playing Fewer Matchups than Others.

The report provides yet another easy way to check the evenness of your schedules. If there are teams that play fewer games than the rest of the teams do, they'll show up on this report, helping you figure out which teams might need a couple extra games scheduled. In addition, this report suggests a best match for the team and an available timeslot for the teams.

To request the report, simply select the division and the schedule you want to examine on the window that displays. Then click the **Export** button and save the file.

**Example of Teams Playing Fewer Matchups than Others report**

**Team Special Requests**

**How to Access:** Select Reports → Team Special Requests.

The Team Special Requests report displays all special request games for a certain division or all divisions. On the View Special Requests for Division window, select the division to run the report for. Then click the **Export** button. The following window displays, with special request games listed by division (if All Divisions was selected), and then listed by team. The date of each game,
whether the game is home or away, and the team against which they’ll play are also included.

You can add your own notes directly into the window and copy the contents of the window by clicking the **Copy to Clipboard** button.

**Team Time Constraints**

**How to Access:** Select Reports → Team Special Requests.

The Team Time Constraints report displays a listing of all time constraints in your schedule. You can request a list for a certain division or all divisions. On the View Team Time Constraints window, select the division to run the report for. Then click the **View** button. The following window displays, with each team listed by division and time constraints listed under the team.
You can export the time constraint information to a template (CSV) file by clicking the **Export to Template File** button. Your computer's file browser will open, and you can save the file.

In addition, you can add your own notes directly into the window and copy the contents of the window by clicking the **Copy to Clipboard** button.

**Team Results Report**

**How to Access:** Select Reports → Team Results Report.

The Team Results report shows all scores for a team or all teams in a division. You can export this report in HTML or CSV format for easy sharing. Additional options include whether to export each team's results as a separate file, whether to include division names, and whether to include across-division game results.
Following is an example of the Team Results report exported in HTML format.

**Game Results**

**East League Bluejays**

<table>
<thead>
<tr>
<th>W/L</th>
<th>PF</th>
<th>PA</th>
<th>Date</th>
<th>V Div</th>
<th>Visitor</th>
<th>H Div</th>
<th>Home</th>
</tr>
</thead>
<tbody>
<tr>
<td>W</td>
<td>5</td>
<td>4</td>
<td>3/18/2017</td>
<td>East League</td>
<td>Bluejays</td>
<td>East League</td>
<td>Robins</td>
</tr>
<tr>
<td>L</td>
<td>8</td>
<td>9</td>
<td>3/18/2017</td>
<td>East League</td>
<td>Cardinals</td>
<td>East League</td>
<td>Bluejays</td>
</tr>
<tr>
<td>W</td>
<td>8</td>
<td>5</td>
<td>3/25/2017</td>
<td>East League</td>
<td>Bluejays</td>
<td>East League</td>
<td>Skylarks</td>
</tr>
<tr>
<td>L</td>
<td>1</td>
<td>3</td>
<td>3/27/2017</td>
<td>East League</td>
<td>Finches</td>
<td>East League</td>
<td>Bluejays</td>
</tr>
<tr>
<td>L</td>
<td>2</td>
<td>4</td>
<td>4/1/2017</td>
<td>East League</td>
<td>Robins</td>
<td>East League</td>
<td>Bluejays</td>
</tr>
<tr>
<td>W</td>
<td>8</td>
<td>4</td>
<td>4/8/2017</td>
<td>East League</td>
<td>Bluejays</td>
<td>East League</td>
<td>Cardinals</td>
</tr>
<tr>
<td>W</td>
<td>7</td>
<td>4</td>
<td>4/12/2017</td>
<td>East League</td>
<td>Skylarks</td>
<td>East League</td>
<td>Bluejays</td>
</tr>
<tr>
<td>W</td>
<td>3</td>
<td>2</td>
<td>4/17/2017</td>
<td>East League</td>
<td>Bluejays</td>
<td>East League</td>
<td>Finches</td>
</tr>
<tr>
<td>L</td>
<td>1</td>
<td>4</td>
<td>4/24/2017</td>
<td>East League</td>
<td>Bluejays</td>
<td>East League</td>
<td>Robins</td>
</tr>
<tr>
<td>L</td>
<td>1</td>
<td>9</td>
<td>4/29/2017</td>
<td>East League</td>
<td>Cardinals</td>
<td>East League</td>
<td>Bluejays</td>
</tr>
<tr>
<td>W</td>
<td>9</td>
<td>2</td>
<td>4/29/2017</td>
<td>East League</td>
<td>Bluejays</td>
<td>East League</td>
<td>Skylarks</td>
</tr>
<tr>
<td>L</td>
<td>2</td>
<td>3</td>
<td>5/6/2017</td>
<td>East League</td>
<td>Finches</td>
<td>East League</td>
<td>Bluejays</td>
</tr>
</tbody>
</table>
Game Scores Reporting Sheet

**How to Access:** Select Reports → Game Scores Reporting Sheet.

Use this report to request a list of game scores for a certain schedule, as well as within a certain date range. For example, you can view a list of scores for only games that were played in June.

Once you request the report, the following window displays with the indicated game scores.
What's on this Screen

- **Use Multi-Column Sort.** Select this check box to use the multi-column sorting you defined on the Multi Column Sort window (described below). If this check box is not selected, the columns will be sorted in chronological order.

- **Multiple Column Sort.** Click the (Multiple Column Sort) icon to access the Multi Column sort window, where you can chose columns to sort by and indicate whether the information should be sorted in alphabetical order.

- **Preferences.** Click the (Preferences) icon to open a window where you can select the columns to display.

- **Save Preferences.** Click the (Save Preferences) icon to save your defined preferences. The Save Preferences window will show, where you can specify which settings should be retained when the Game Score report is loaded in the future.

- **Manage Preferences.** Click the (Manage Preferences) icon to indicate whether the preferences you specified on the Save Preferences window should display when you load the Game Score report.
- **Print.** Click the 🖨️ (Print) icon to print the Game Score report. When you print, you'll be presented with a list of options, including which pages and columns should be printed.

- **Print to PDF.** Click the 🖨️ (Print to PDF) icon to export the Game Score report as a PDF file. A window will display where you can type in a report title and other instructions.

- **Export to HTML.** Click the 🖨️ (Export to HTML) icon to export your Game Score report as an HTML file. Before you export, you'll see a window where you can enter a title for the file and instructions that will display at the top of the report.

- **Export.** Click the 🖨️ (Export) icon to export the Team Balance screen to a variety of formats, including Microsoft Excel and Word. On the window that displays, you can indicate which pages and columns should be included in the exported file.

- **Use One Column for Score.** By default, the visiting team's score and the home team's score display in their own columns. Select this check box to show the scores in one column. For example, if the visiting team scored 5 and the home team scored 4, the **Score** column would display 5-4.

  In addition, you can select one of the option buttons below to indicate whether the visiting team's score or the home team's score should display first in the combined **Score** column.
View Menu

The View menu contains all the options you need to create, view, and manage your schedules. Many of the options in this menu will be the “heart” of your typical operations in Diamond Scheduler. Therefore, it would benefit you to be as familiar as possible with options like the Master Calendar screen, Timeslot Calendar screen, and Home screen before starting to create your schedule files.

Master Calendar

**How to Access:** Select View → Master Calendar.

You can also press the Ctrl+M hot key combo, select **Master Calendar** from the **Navigation** field on the Timeslot Detail panel or the Filters panel, or click the **Master Calendar** button on the Timeslots Calendar panel.

The Master Calendar screen is where you can see a calendar view of all your timeslots and scheduled games once you’ve created them. This screen is packed with functionality, so we’ll break it up into smaller pieces to go over the screen in better detail.
Timeslot Detail Panel

The Timeslot Detail panel can be found on the left side of the Master Calendar screen or Game List by clicking the Timeslot Detail tab. This panel shows you detailed (hence, the name) information about a selected timeslot, such as the start and end times, teams and venue, and game score or other notes. This panel also lets you manually update these details as needed, which can be helpful for making minor tweaks after automatic scheduling is completed.
Most of the options are self-explanatory, but it’s worth pointing out a couple of the specialty options.

- **Navigation.** You can quickly switch between several key screens, such as the Master Calendar, Game List, or Standings screen by selecting the screen name in this field.
• **Exhibition Game.** Mark the game as an "exhibition game," which includes a visitor and a home team, but does not count in standings or rankings.

• **TBD Game.** Mark the timeslot as a "to be determined' game. This option can only be selected for unscheduled timeslots.

• **Include Out-of-League.** Indicate if you want out-of-league teams included in the choices for the Visitor field and Home field.

• **Score.** You can record the score of a game using these fields. The visiting team displays on top and the home team displays on bottom, like usual.

---

**Filters Panel**

The Filters panel is found on the left side of several screens, such as the Master Calendar screen or Game List, by clicking the Filters tab. This panel lets you filter out certain divisions, teams, or venues, which can be useful for simplifying the view and allowing you to focus on one schedule at a time.

If a check box is selected, the corresponding division/team/venue will display on screen. If the check box is not selected, the corresponding information doesn't display.

**Note:** You can customize whether teams should display if their division is not selected using the Hide Filtered Division Teams option.
What's on this Screen

- **Navigation.** You can quickly switch between several key screens, such as the Master Calendar, Game List, or Standings screen by selecting the screen name in this field.

- **Lock Filters.** You can "lock" the filters you currently have selected using this option. When you leave the screen and then return to it, the filters you had set when you locked them will still be selected. Otherwise, the default filter settings will be reapplied.

- **.heap (Save) icon.** If you have a certain set of filters you use frequently, you can save the settings as a "filter file" and can open the file at any time. To save the current filter settings, click the heap (Save) icon. This can save you time if you have a view you like to use often, but don’t want to spend time resetting the filters each time.

- **.heap (Open) icon.** Click this icon to display your computer's browser file and open a save filter file.

- **Timeslot View.** If only one division is selected in the Division box, you can choose whether to display unscheduled timeslots for all schedules or for just the current division's schedule.

- **Between Two.** Select this option to show only games between two particular teams. For example, you may have Doves and Magpies selected in your Team box, which means that all games where the Doves play and all games where the Magpies play display in the calendar. When you select Between Two, only games in which the Doves play the Magpies are shown.

- **Checked Divs.** Display only timeslots associated with venues specific to the divisions selected in the division list above. To remove this filter, you can either clear this check box or click the Remove Venues Filters button at the top of the calendar.

Master Calendar Toolbar

The Master Calendar toolbar contains the following buttons.

- **Save to PDF.** Save a picture of the current calendar view to PDF. Only items visible on the current screen will be captured.
• **Print.** Print a picture of the current calendar view.

• **Export to HTML.** Export the entire calendar to HTML. When this option is clicked, the following window displays, where you can customize the information that is included.

![Export to HTML window]

• **Home.** Click this button to return to the Home screen, which includes the Divisions, Teams, Venues, People, and Schedule tabs.

**Calendar View Toolbar**

The Calendar View toolbar includes check boxes to display or hide certain timeslots, including games, practices, open timeslots, or events. You can also choose to highlight all open timeslots.

[Calendar View toolbar]

Additionally, you can use the arrows next to the date to go to the previous or next date range based on the view you’re currently in. For example, if you’re on March in Month view, clicking the ➔ (Next) icon will go to April.
Right-Click Options

The right-click options menu, accessed by – yep – right-clicking in the Master Calendar, provides you with over 60 options for adding, changing, or removing timeslots on your schedules.

**Note:** The right-click options menu is not available in Year view.

### Select

**TIP:** You can select multiple congruous timeslots by holding the Ctrl key and dragging the mouse over the timeslots to "lasso" select. You can also select multiple incongruous timeslots by holding the Ctrl key and clicking on individual timeslots.

- **Select Day's Timeslots.** Select all of the timeslots in the clicked-on day.
- **Select Week's Timeslots.** Select all of the timeslots in the clicked-on week.
- **Select Month's Timeslots.** Select all of the timeslots in the clicked-on month.
- **Select All Timeslots Before Selected Date.** Select all of the timeslots before the clicked-on day. Does not include clicked-on day.
- **Select All Timeslots After Selected Date.** Select all of the timeslots after the clicked-on day. Includes the clicked-on day.
- **Select All Timeslots.** Select all timeslots in the calendar.
- **Custom Select.** Provides you with a set of options to make a custom selection of multiple timeslots. For example, you can define a custom selection of only Monday games from May to July that are scheduled in your first venue. You can also include or exclude specific types of timeslots from the selection, such as unscheduled timeslots, practices, or exhibition games.

### Create

- **New Timeslot.** Add a new timeslot to the clicked-on day. A window displays prompting you to pick which venue the timeslot should be scheduled for. An unscheduled timeslot is created using the default time length defined on the Timeslot Calendar screen.
• **New Special Event.** Add a new special event timeslot to the clicked-on day. A window displays prompting you to pick which venue the timeslot should be scheduled for. Then the Event Information panel displays on the left side of the screen, where you can define the information for the event, including whether it's an all-day event, the event title, and the start and end times.

---

**Reserve**

• **Reserve/Unreserve Selected Timeslots.** Reserve or unreserve the selected timeslot. A reserved timeslot is excluded when a schedule is automatically created.

• **Reserve/Unreserve for TBD Game.** Reserve or unreserve the selected timeslot for a "to be determined" game. A reserved timeslot is excluded when a schedule is automatically created.

• **Remove Reservations from All Timeslots.** Remove reservations from all timeslots on the calendar.

---

**Associate**

• **Associate Timeslot with Division.** Associate the selected timeslot with a particular division. A window displays, where you can select your division.

• **Associate Timeslot with No Divisions (Change to Unassigned).** Remove any associated divisions from the selected timeslot.

• **Associate Selected Games with a Schedule.** Associate the selected timeslot with a particular schedule. A window displays, where you can select the schedule to associate.

---

**Convert**

• **Convert Timeslot to Special Event.** Convert the existing selected timeslot to a special event timeslot.

• **Convert Timeslot to Game Timeslot.** Convert the existing selected timeslot to a game timeslot.

• **Convert Game to Practice Game.** Convert the existing selected scheduled game timeslot to a practice game timeslot.
Split/Modify Timeslots

- **Slice Selected Timeslots into Segments.** You can break an existing timeslot into multiple timeslots using the Split/Modify Timeslots option. The following window displays, allowing you to choose how long the timeslots should be, "snap" the timeslot to the top of the hour or the half hour, and how long the break should be between the next timeslot.

![Slice Timeslots](image)

- **Convert Selected to Split Practice Timeslot.** Convert the selected timeslot into a split practice timeslot.

Modify Timeslots

- **Change Duration of Selected Timeslots.** You can change the duration of a selected timeslot using the New Timeslot Duration window, accessed by choosing this right-click option.
Enter the new length of the timeslot in the **Hours** and **Minutes** fields. Then select whether the new duration should be extended forward from the beginning of the current timeslot or backward from the end of the timeslot. For example, if you currently have a timeslot from 10:00-11:00, and you enter a new duration of 2 hours with an anchor at the end of the timeslot, the new time range of the slot will be 9:00-11:00.

**Filter by Division or Schedule**

- **Display Timeslots Associated with Specific Divisions.** This option works more or less like the Division filter in the Filters panel, but allows you to choose a few more specific limits.
You can include all multi-division timeslots, multi-division timeslots where the selected division is not included, and all unassigned timeslots.

If you want to return to your previous view (without the filters), click the **Remove Venues Filters** button at the top of the screen.

- **Display Timeslots Associated with Specific Schedules.** This filter allows you to look at only one schedule at a time. Just click this option, select the schedule on the window that displays, and click the **OK** button. You can click the **Remove Venues Filters** button at the top of the screen to remove the filter at any time.

**Display Tooltip Information**

- **Display Games and Timeslots in Month View.** Enable this option to display details about all games and timeslots in a day when you hover over the day in Month view.

- **Display Teams of Timeslot Divisions Not Playing on Rollover.** Enable this option to display a list of all teams not playing on a day when you hover over the day on the calendar.
• **Display Teams of One Division Not Playing on Rollover.** When you enable this option, you'll be prompted to pick a division. Teams in this division are displayed in a tooltip if they are not playing on that day.

• **Display Teams of Timeslot Divisions Playing on Rollover.** Select this option to display all teams playing on a day when you hover over the day in the calendar.
• **Display Teams of One Division Playing on Rollover.** When you enable this option, you’ll be prompted to pick a division. Teams in this division are displayed in a tooltip if they are playing on that day.

• **Display Home Teams for Venue on Rollover.** Enable this option to display a list of the home teams assigned to the venue associated with a timeslot when you hover over the timeslot in the calendar.
Copy/Paste/Delete

- **Copy.** Copy the selected timeslot.
- **Cut.** Cut the selected timeslot.
- **Paste.** Paste the copied or cut timeslot.
- **Delete.** Delete the selected timeslot. You can also use the Delete key.

  **Note:** This option is only enabled in Day view or Week view.

- **Copy Day as Template.** Copy the clicked-on day as a template to paste to another day on the calendar. This option copies all timeslots and games on the day.

- **Copy Week as Template.** Copy the clicked-on week as a template to paste to another week on the calendar. This option copies all timeslots and games in the week.

- **Copy Week and Paste Until Date.** Copy the timeslots in the selected week and repeat a paste of the same week until a certain date. A calendar displays, allowing you to pick a specific date on which the pasted week should start. This option is great for creating timeslots that repeat through the whole schedule – for example, if your league will always play Mondays, Wednesdays, and Fridays at 5:00.

- **Copy Selected Timeslots and Paste Until Date.** Copy the selected timeslots and repeat a paste of the same timeslots until a certain date. A calendar displays, allowing you to pick a specific date on which the pasting should start.
**TIP:** You can select multiple congruous timeslots by holding the Ctrl key and dragging the mouse over the timeslots to "lasso" select. You can also select multiple incongruous timeslots by holding the Ctrl key and clicking on individual timeslots.

- **Copy Existing Games and Map to Remaining Open Timeslots.** This function will take the existing, scheduled games and attempt to repeat the sequence for the remainder of the season using available timeslots starting after the last day of the existing sequence of games. You can choose to either continue the pattern until all open timeslots are used or to repeat the pattern a certain number of times.

- **Paste Day from Template.** Paste the copied day template.

- **Paste Week from Template.** Paste the copied week template.

### Switch and Flip

- **Switch Game Timeslots.** Select two game timeslots (hold the Ctrl key and click each to select two timeslots at a time) and select this option to switch the games but retain the timeslots. For example, suppose the Robins play the Finches at 10:00 on the 9th and the Hummingbirds play the Swallows at 4:00 on the 16th. When you select this option, the Robins will now play Swallows at 4:00 on the 16th and the Hummingbirds will play the Swallows at 10:00 on the 9th.

- **Flip Home and Away.** Flip the home team and away team for a game timeslot. For example, if the Robins (visitors) play the Finches at home, this option will make the Finches (visitors) play the Robins as the home team.

- **Flip Home and Away for all Games.** Flip the home team and away team for all games in the schedule. This option flips the teams for both locked and unlocked games.

- **Flip Home and Away for Unlocked Games.** Flip the home team and away team for only all unlocked games in the schedule.

### Reschedule and Clear

- **Move to Reschedule List.** Move the selected game to the Reschedule List, indicating that it needs to be rescheduled for something like a rainout or other circumstance.

- **Show Reschedule List.** Display a list of games that have been added to the reschedule list on the Games to Reschedule window.
• **Clear Teams and Leave Timeslot.** Unschedule the teams from the selected game, but leave the time, venue, and division association for the timeslot.

---

**Lock Games**

• **Lock Selected Games.** Lock the selected games. When a game is locked, a yellow lock icon or yellow bar displays on the timeslot, depending on the calendar view.

  **TIP:** You can select multiple congruous timeslots by holding the Ctrl key and dragging the mouse over the timeslots to “lasso” select. You can also select multiple incongruous timeslots by holding the Ctrl key and clicking on individual timeslots.

• **Lock Games for Specific Schedules.** Lock all games for a specific schedule. The Schedule Lock window displays, where you can pick the schedule. When a game is locked, a yellow lock icon or yellow bar displays on the timeslot, depending on the calendar view.

• **Lock All Scheduled Games.** Lock all scheduled games. When a game is locked, a yellow lock icon or yellow bar displays on the timeslot, depending on the calendar view.

• **Lock All Games On or Before Selected Date.** Lock all games on or before the selected date. When a game is locked, a yellow lock icon or yellow bar displays on the timeslot, depending on the calendar view.

• **Unlock Selected Games.** Unlock all the selected games.

  **TIP:** You can select multiple congruous timeslots by holding the Ctrl key and dragging the mouse over the timeslots to “lasso” select. You can also select multiple incongruous timeslots by holding the Ctrl key and clicking on individual timeslots.

• **Unlock Games for Specific Schedules.** Unlock all games for a specific schedule. The Schedule Lock window displays, where you can pick the schedule.

• **Unlock All Games.** Unlock all scheduled games.

• **Unlock All Games On or Before Selected Date.** Unlock all games on or before the selected date.
Notes

- **Add a Note.** You can add a note to a game slot or timeslot to help you remember important things. Notes will be viewable in both the Master Calendar and the Game List.

If a note exists on a slot, a note icon displays on the slot, and the note will display in the tooltip when you hover over the slot.

- **Edit Note.** Displays the note so you can edit the content or note type.
- **Delete Notes.** Deletes the note for the game or timeslot.
Move Games

- **Move Selected Timeslots.** Move the selected timeslots to a different start date using a window similar to the Move Schedule window, which allows you to shift your schedule to a specific date or by a number of days, hours, and minutes.

- **Move Entire Schedule.** You can move the start date for your entire schedule at one time using the Move Schedule window, which allows you to shift your schedule to a specific date or by a number of days, hours, and minutes.

Show Window

- **Team Balance Window.** Display the Team Balance window, which shows you a list of your teams for each division with counts including how many times a team plays other teams, and how many times in those times the team plays as a visitor and as a home team.

- **Venue Balance Window.** Display the Venue Balance window, which shows you a list of your venues, including the teams that play at that venue and the number of times each team plays at the venue.

Calendar View Options

The Calendar View options include the following.

- **Stack.** Select the Stack check box to display your slots in a “stacked” format. This option only changes the view on the Day or Week view.
• **Zoom In.** Zoom in on the screen, widening the timeslots to show more detail.

  **Note:** This option is only enabled for Week view and Day view.

• **Zoom Out.** Zoom out on the screen, condensing the timeslots to show less detail.

  **Note:** This option is only enabled for Week view and Day view.

• **Show today in current view.** This button functions as a “Jump to Today” button. If you want to quickly return to the current day, click this button.

• **Go to a specific date.** Click this button to display a calendar, which you can quickly scroll through to jump to a specific date on the calendar.

• **Day.** View the calendar by day.

• **Week.** View the calendar by week.

• **Month.** View the calendar by month.

• **Year.** View the calendar by year.

• **Configure days that are displayed on the calendar.** You can customize how the calendar displays by clicking this button. You’re presented with the **Days of Week Settings window**, which includes options for which day of the week the calendar views should begin on and which days of the week should display on the calendar. For example, if your league doesn’t play on weekends, you can hide Sundays and Saturdays, expanding the real estate of your weekday slots.
**Timeslot Calendar**

**How to Access:** Select View → Timeslot Calendar.

You can also press the Ctrl+T hot key combo or select Master Calendar from the Navigation field on the Timeslot Detail panel or the Filters panel.

The Timeslot Calendar allows you to view your schedules by venue, and provides tons of options for creating and associating timeslots for venues to certain divisions. Because there are so many options on this screen, we'll break it up into the following sections to describe them in better detail.
Navigating the Timeslot Calendar Screen

Because there is so much functionality on this screen, it will also be beneficial to give you an overview of how the screen generally works.

Double-clicking on an empty day of the calendar when in Month view will toggle to the Week view of the calendar. Notice the days of the week are displayed in the headers and time of day is displayed on the Y axis.

Double-clicking on a time of day when in Week view creates a timeslot. Before double-clicking on a time, indicate which divisions can use the timeslots you are about to create by selecting the appropriate check boxes in the Division box at the upper right.

If you had multiple divisions in the file, you could certainly indicate that multiple divisions could use a timeslot. However, it's also common to indicate that early timeslots are used by Division 1 and later timeslots are used by Division 2.

You can also leave timeslots unassigned to any divisions, then tell the program to use unassigned timeslots when you schedule.

Once you create a template week of timeslots by double-clicking across the week view, you can right click on the calendar and choose the Copy Week and Paste Until Date option to quickly clone the week's timeslots as a recurring pattern until the end of the season.

Timeslot Calendar Toolbar

The Timeslot Calendar toolbar contains the following buttons.

- **Save to PDF.** Save a picture of the current calendar view to PDF. Only items visible on the current screen will be captured.
- **Print.** Print a picture of the current calendar view.
- **Export to HTML.** Export the entire calendar to HTML. When this option is clicked, the following window displays, where you can customize the information that is included.
• **Close Calendar.** Click this button to return to the Home screen, which includes the Divisions, Teams, Venues, People, and Schedule tabs.

**Calendar View Toolbar**

The Calendar View toolbar includes a field used to filter which venue displays on the calendar.

Additionally, you can use the arrows next to the date to go to the previous or next date range based on the view you’re currently in. For example, if you’re on April in Month view, clicking the (Next) icon will go to June.

**Right-Click Options**

The Timeslot Calendar includes a right-click options menu, providing you with multiple options for adding, changing, or removing timeslots on your schedules.

**Note:** The right-click options menu is not available in Year view.
Select

TIP: You can select multiple congruous timeslots by holding the Ctrl key and dragging the mouse over the timeslots to “lasso” select. You can also select multiple incongruous timeslots by holding the Ctrl key and clicking on individual timeslots.

- **Select Day’s Timeslots.** Select all of the timeslots in the clicked-on day.
- **Select Week’s Timeslots.** Select all of the timeslots in the clicked-on week.
- **Select Month’s Timeslots.** Select all of the timeslots in the clicked-on month.
- **Select Visible Timeslots.** Select only the timeslots that are visible on the current view of the calendar. For example, if you have 5 timeslots in a day and only 4 are showing (the fifth one displays as a "+1" after the first four slots), clicking this option will choose only the first four visible timeslots.
- **Select All Timeslots for This Venue.** Select all timeslots in the calendar for the currently displayed venue.

Create

- **Add a Timeslot.** Add a new timeslot to the clicked-on day. An unscheduled timeslot is added for the currently displayed venue, but unassigned to a team.
- **Create Special Event.** Add a new special event timeslot to the clicked-on day for the currently displayed venue. The Event Information panel displays on the right side of the screen, where you can define the information for the event, including whether it’s an all-day event, the event title, and the start and end times.

Reserve

- **Reserve/Unreserve Selected Timeslots.** Reserve or unreserve the selected timeslot. A reserved timeslot is excluded when a schedule is automatically created.
- **Remove Reservations from All Timeslots.** Remove reservations from all timeslots on the calendar.
Convert

- **Convert Timeslot to Special Event.** Convert the existing selected timeslot to a special event timeslot.
- **Convert Timeslot to Game Timeslot.** Convert the existing selected timeslot to a game timeslot.

Split

- **Slice Selected Timeslots into Segments.** You can break an existing timeslot into multiple timeslots using the Split/Modify Timeslots option. The following window displays, allowing you to choose how long the timeslots should be, "snap" the timeslot to the top of the hour or the half hour, and how long the break should be between the next timeslot.

![Slice Timeslots](image)

- **Convert to Split Practice Timeslot.** Convert the selected timeslot into a split practice timeslot.

Copy/Paste/Delete

- **Copy.** Copy the selected timeslot.
- **Paste.** Paste the copied or cut timeslot.
Copy/Paste/Delete Special

- **Copy Week and Paste Until Date.** Copy the timeslots in the selected week and repeat a paste of the same week until a certain date. A calendar displays, allowing you to pick a specific date on which the pasted week should start. This option is great for creating timeslots that repeat through the whole schedule – for example, if your league will always play Mondays, Wednesdays, and Fridays at 5:00.

- **Copy Selected Timeslots and Paste Until Date.** Copy the selected timeslots and repeat a paste of the same timeslots until a certain date. A calendar displays, allowing you to pick a specific date on which the pasting should start.

  **TIP:** You can select multiple congruous timeslots by holding the Ctrl key and dragging the mouse over the timeslots to “lasso” select. You can also select multiple incongruous timeslots by holding the Ctrl key and clicking on individual timeslots.

- **Copy Day as Template.** Copy the clicked-on day as a template to paste to another day on the calendar. This option copies all timeslots and games on the day.

- **Copy Week as Template.** Copy the clicked-on week as a template to paste to another week on the calendar. This option copies all timeslots and games in the week.

- **Copy All Timeslots from this Venue.** Copy all of the timeslots for the currently displayed venue.

- **Clone All Timeslots from this Venue to All Venues.** Copy all of the timeslots for the currently displayed venue and paste them to the Timeslot Calendar for all other venues. This is useful when multiple venues are used in a league, but the schedules for all teams are the same.

- **Paste Day from Template.** Paste the copied day template.

- **Paste Week from Template.** Paste the copied week template.

- **Paste Timeslots Copied from Another Venue.** If you’ve used the Copy All Timeslots from this Venue option to copy timeslots in one venue, you can use this option to paste those timeslots into the calendar for a different venue.

- **Copy Timeslot Start and End Times.** You can easily change the start and end times for a timeslot by copying the start and end time of an existing timeslot. Use this option to copy the start and end times of an existing timeslot.
- **Paste Stored Start and End Times.** You can easily change the start and end times for a timeslot by copying the start and end time of an existing timeslot. Use this option to paste the start and end times of an existing timeslot to the selected timeslot.

- **Delete Selected Timeslots.** Delete the selected timeslot.

- **Delete All Timeslots for this Venue.** Delete all the timeslots for the currently displayed venue.

- **Delete All Timeslots in this File.** Delete all the timeslots for all venues in the current schedule file.

**Modify Timeslots**

- **Move Selected Timeslots.** Move the selected timeslots to a different start date using a window similar to the Move Schedule window, which allows you to shift your schedule to a specific date or by a number of days, hours, and minutes.

- **Move All Timeslots for this Venue.** Move all of the timeslots for the venue to a different start date using a window similar to the Move Schedule window, which allows you to shift your schedule to a specific date or by a number of days, hours, and minutes.

- **Change Duration of Selected Timeslots.** You can change the duration of a selected timeslot using the New Timeslot Duration window, accessed by choosing this right-click option.

![New Timeslot Duration Window](image)

Enter the new length of the timeslot in the **Hours** and **Minutes** fields. Then select whether the new duration should be extended forward from the beginning of the current timeslot or backward from the end of the timeslot. For example, if you currently have a timeslot from 10:00-11:00, and you
enter a new duration of 2 hours with an anchor at the end of the timeslot, the new time range of the slot will be 9:00-11:00.

- **Change Duration of All Venue Timeslots.** This is the same option as above, but for all of the timeslots for the currently displayed venue.

- **Close Time Gaps Between Selected Timeslots.** Close the time gap between selected timeslots. For example, if you have a 12:00-1:00 game and a 2:00-3:00 game, closing the time gaps will move the second game to 1:00-2:00.

- **Close Time Gaps for All Venue Timeslots.** This is the same option as above, but does so for all of the timeslots for the currently displayed venue.

**Notes**

- **Add a Note.** You can add a note to a game slot or timeslot to help you remember important things.

If a note exists on a slot, a note icon displays on the slot, and the note will display in the tooltip when you hover over the slot.
• **Edit Note.** Displays the note so you can edit the content or note type.

• **Delete Notes.** Deletes the note for the game or timeslot.

## Calendar View Options

The Calendar View options include the following.

- **Stack.** Select the Stack check box to display your slots in a “stacked” format. This option only changes the view on the Day or Week view.

- **Zoom In.** Zoom in on the screen, widening the timeslots to show more detail.

  **Note:** This option is only enabled for Week view and Day view.

- **Zoom Out.** Zoom out on the screen, condensing the timeslots to show less detail.

  **Note:** This option is only enabled for Week view and Day view.
• **Show today in current view.** This button functions as a “Jump to Today” button. If you want to quickly return to the current day, click this button.

• **Go to a specific date.** Click this button to display a calendar, which you can quickly scroll through to jump to a specific date on the calendar.

• **Day.** View the calendar by day.

• **Week.** View the calendar by week.

• **Month.** View the calendar by month.

• **Year.** View the calendar by year.

• **Configure days that are displayed on the calendar.** You can customize how the calendar displays by clicking this button. You’re presented with the Days of Week Settings window, which includes options for which day of the week the calendar views should begin on and which days of the week should display on the calendar. For example, if your league doesn’t play on weekends, you can hide Sundays and Saturdays, expanding the real estate of your weekday slots.

**Timeslots Calendar Panel**

The Timeslots Calendar panel provides a number of options for modifying timeslots on the calendar.

**What's on this Screen**

• **Divisions box.** You can select a timeslot and then select a division to associate the division to the timeslot. You can also click the 🎨 (Color Palette) icon next to a division to choose the color timeslots for the division should display in.

• **New Division.** Click the **New Division** button to quickly add a new division quickly, in case you are in the middle of creating timeslots and see that you forgot to create a division that is now needed. All you’ll have to enter for now is the division name and abbreviation. You can always add extra information using the **Divisions tab** once you’ve added it.

• **Split for practices into.** This setting allows you to split a venue into sub-venues for practice. This is common with hockey and other sports that do not require a full venue for teams to practice.

Check this option and enter the number of practices to split a timeslot or game slot into. Then select the slot to split and click the **Apply Above Properties** button.
• **Use Only for Practices.** Check this option, select an unscheduled timeslot, and then click the **Apply Above Properties** button to indicate the timeslot should only be used for practices. This will exclude the timeslot from being scheduled for a game when you automatically schedule.

• **Copy division assignments.** Click the (Copy division assignments) icon and then click a timeslots to copy the existing division assignments of that timeslot. Select a different timeslots and then click the **Apply Above Properties** button to apply the division assignments to that timeslot.

• **Apply Above Properties.** Click this button to apply any settings you’ve defined above, including division assignments, splitting the slot into practices, or using the slot only for practices.

• **Venue timeslots.** This field shows the number of timeslots that exist for the currently displayed venue.

• **Total timeslots.** This field shows the number of timeslots that exist for all venues in the schedule file.

• **Default Length.** Enter the length of time that timeslots should automatically be scheduled for when created. You can select a timeslot and click Apply to set the slot to the default length.

• **Date.** This field either displays the date for the selected timeslot, or you can change the date for the timeslot. You can click the (Calendar) icon to pick a date.

• **Start.** This field either displays the start time for the selected timeslot, or you can change the start time for the timeslot.

• **End.** This field either displays the end time for the selected timeslot, or you can change the end time for the timeslot.

• **Master Calendar.** Click this button to access the **Master Calendar screen.**

• **Done.** Click this button to close the Timeslot Calendar and display the Home screen.

---

**Game List**

**How to Access:** Select View → Game List.

The Game List, as the name most likely indicates, provides you with a complete list of your games, but with handy filtering options, including the Timeslot Detail panel and the Filters panel. You can also filter whether to display only games, practices, open timeslots, or events.
We’ll break this screen up into smaller pieces to go over the features in better detail.

Timeslot Detail Panel

The Timeslot Detail panel can be found on the left side of the Master Calendar screen or Game List by clicking the Timeslot Detail tab. This panel shows you detailed (hence, the name) information about a selected timeslot, such as the start and end times, teams and venue, and game score or other notes. This panel also lets you manually update these details as needed, which can be helpful for making minor tweaks after automatic scheduling is completed.
Most of the options are self-explanatory, but it’s worth pointing out a couple of the specialty options.

- **Navigation.** You can quickly switch between several key screens, such as the Master Calendar, Game List, or Standings screen by selecting the screen name in this field.
• **Exhibition Game.** Mark the game as an "exhibition game," which includes a visitor and a home team, but does not count in standings or rankings.

• **TBD Game.** Mark the timeslot as a "to be determined" game. This option can only be selected for unscheduled timeslots.

• **Include Out-of-League.** Indicate if you want out-of-league teams included in the choices for the Visitor field and Home field.

• **Score.** You can record the score of a game using these fields. The visiting team displays on top and the home team displays on bottom, like usual.

---

**Filters Panel**

The Filters panel is found on the left side of several screens, such as the Master Calendar screen or Game List, by clicking the Filters tab. This panel lets you filter out certain divisions, teams, or venues, which can be useful for simplifying the view and allowing you to focus on one schedule at a time.

If a check box is selected, the corresponding division/team/venue will display on screen. If the check box is not selected, the corresponding information doesn't display.

**Note:** You can customize whether teams should display if their division is not selected using the Hide Filtered Division Teams option.
What's on this Screen

- **Navigation.** You can quickly switch between several key screens, such as the Master Calendar, Game List, or Standings screen by selecting the screen name in this field.
• **Lock Filters.** You can "lock" the filters you currently have selected using this option. When you leave the screen and then return to it, the filters you had set when you locked them will still be selected. Otherwise, the default filter settings will be reapplied.

• **Save (Save) icon.** If you have a certain set of filters you use frequently, you can save the settings as a "filter file" and can open the file at any time. To save the current filter settings, click the Save (Save) icon. This can save you time if you have a view you like to use often, but don’t want to spend time resetting the filters each time.

• **Open (Open) icon.** Click this icon to display your computer’s browser file and open a save filter file.

• **Timeslot View.** If only one division is selected in the Division box, you can choose whether to display unscheduled timeslots for all schedules or for just the current division’s schedule.

• **Between Two.** Select this option to show only games between two particular teams. For example, you may have Doves and Magpies selected in your Team box, which means that all games where the Doves play and all games where the Magpies play display in the calendar. When you select Between Two, only games in which the Doves play the Magpies are shown.

• **Checked Divs.** Display only timeslots associated with venues specific to the divisions selected in the division list above. To remove this filter, you can either clear this check box or click the Remove Venues Filters button at the top of the calendar.

### Calendar View Toolbar

The Calendar View toolbar includes check boxes to display or hide certain timeslots, including games, practices, open timeslots, or events. You can also choose to show only today’s games or only games within a certain date range.

The following options are included in this toolbar.

• To display only certain types of timeslots, select a check box to show the corresponding type. For example, select the Games check box to show game slots.

• Click the (Today) icon to show only games scheduled on today’s date in the Game List.

• Click the (Date Range) icon to select a range of dates in the Game List using the Date Range Chooser window.
Finally, you can click the Home button to display the Home screen.

Game List Toolbar

The Game List toolbar lets you control, navigate, sort, and export the games listed on the Game List.

The following icons and options are available.

- **Items __ to ___ of ___.** This field lists how many timeslots you're viewing on the current page out of the total number of timeslots shown.

- **Page __ of ___.** This field shows you which page of the Game List you're on out of the total number of pages shown.

- **First Page.** Click the (First Page) icon to go to the first page of the Game List.

- **Previous Page.** Click the (Previous Page) icon to go to the previous page.

- **Next Page.** Click the (Next Page) icon to go to the next page.

- **Last Page.** Click the (Last Page) icon to go to the last page of the Game List.

- **Go to Page.** Select the page number from the dropdown to go to that page.

- **Use Multi-Column Sort.** Select this check box to use the multi-column sorting you defined on the Multi Column Sort window (described below). If this check box is not selected, the columns will be sorted in chronological order.
• **Multiple Column Sort.** Click the 📊 (Multiple Column Sort) icon to access the Multi Column sort window, where you can choose columns to sort by and indicate whether the information should be sorted in ascending or descending order.

• **Preferences.** Click the 📋 (Preferences) icon to open a window where you can select the columns to display and define how many records should show per page.

• **Save Preferences.** Click the 📋 (Save Preferences) icon to save your defined preferences. The Save Preferences window will show, where you can specify which settings should be retained when the Game List is loaded in the future.

• **Manage Preferences.** Click the 📋 (Manage Preferences) icon to indicate whether the preferences you specified on the Save Preferences window should display when you load the Game List.

• **Print.** Click the 📨 (Print) icon to print the Game List. When you print, you'll be presented with a list of options, such as which pages to print, which columns to include, and whether a preview should be created before printing.

• **Print to PDF.** Click the 📨 (Print to PDF) icon to export the Game List as a PDF file. A window will display where you can type in a report title and choose whether to include coach contact information and venue addresses.

• **Export to HTML.** Click the 📨 (Export to HTML) icon to export your Game List as an HTML file. Before you export, you'll see a window where you can enter a title for the file and choose whether to include a venue address legend or coach name legend, as well as whether to include coaches’ primary phone numbers.

• **Export.** Click the 📨 (Export) icon to export the Game List to a variety of formats, including Microsoft Excel and Word. On the window that displays, you can indicate which pages and columns should be included in the exported file.

### Right-Click Options

The right-click options menu, accessed by right-clicking within the grid on the Game List, provides you with tons of options for copying, rescheduling, or switching timeslots on your schedule.

---

**Copy Cell**

Copy the information in the clicked-on cell.
Copy Row

Copy the information in the selected row.

Copy All Rows

Copy all the rows visible on the current page.

Copy Selected Rows

Copy only the selected rows. You can select multiple rows by holding the Ctrl key (Command on a Mac) and clicking your desired rows.

Switch and Flip

- **Switch Game Timeslots.** Select two game timeslots (hold the Ctrl key and click each to select two timeslots at a time) and select this option to switch the games but retain the timeslots. For example, suppose the Robins play the Finches at 10:00 on the 9th and the Hummingbirds play the Swallows at 4:00 on the 16th. When you select this option, the Robins will now play Swallows at 4:00 on the 16th and the Hummingbirds will play the Swallows at 10:00 on the 9th.

- **Flip Home and Away.** Flip the home team and away team for a game timeslot. For example, if the Robins (visitors) play the Finches at home, this option will make the Finches (visitors) play the Robins as the home team.

- **Flip Home and Away for all Games.** Flip the home team and away team for all games in the schedule. This option flips the teams for both locked and unlocked games.

- **Flip Home and Away for Unlocked Games.** Flip the home team and away team for only all unlocked games in the schedule.

Reschedule and Clear

- **Move to Reschedule List.** Move the selected game to the Reschedule List, indicating that it needs to be rescheduled for something like a rainout or other circumstance.

- **Show Reschedule List.** Display a list of games that have been added to the reschedule list on the Games to Reschedule window.
• **Clear Teams and Leave Timeslot.** Unschedule the teams from the selected game, but leave the time, venue, and division association for the timeslot.

---

**Lock Games**

• **Lock Selected Games.** Lock the selected games. When a game is locked, a yellow lock icon or yellow bar displays on the timeslot, depending on the calendar view.

  **TIP:** You can select multiple congruous timeslots by holding the Ctrl key and dragging the mouse over the timeslots to “lasso” select. You can also select multiple incongruous timeslots by holding the Ctrl key and clicking on individual timeslots.

• **Lock Games for Specific Schedules.** Lock all games for a specific schedule. The Schedule Lock window displays, where you can pick the schedule. When a game is locked, a yellow lock icon or yellow bar displays on the timeslot, depending on the calendar view.

• **Lock All Scheduled Games.** Lock all scheduled games. When a game is locked, a yellow lock icon or yellow bar displays on the timeslot, depending on the calendar view.

• **Lock All Games On or Before Selected Date.** Lock all games on or before the selected date. When a game is locked, a yellow lock icon or yellow bar displays on the timeslot, depending on the calendar view.

• **Unlock Selected Games.** Unlock all the selected games.

  **TIP:** You can select multiple congruous timeslots by holding the Ctrl key and dragging the mouse over the timeslots to “lasso” select. You can also select multiple incongruous timeslots by holding the Ctrl key and clicking on individual timeslots.

• **Unlock Games for Specific Schedules.** Unlock all games for a specific schedule. The Schedule Lock window displays, where you can pick the schedule.

• **Unlock All Games.** Unlock all scheduled games.

• **Unlock All Games On or Before Selected Date.** Unlock all games on or before the selected date.
**Show Window**

- **Team Balance Window.** Display the Team Balance window, which shows you a list of your teams for each division with counts including how many times a team plays other teams, and how many times in those times the team plays as a visitor and as a home team.

- **Venue Balance Window.** Display the Venue Balance window, which shows you a list of your venues, including the teams that play at that venue and the number of times each team plays at the venue.

**Report Options**

The following options are available at the bottom of the Game List screen.

- **Column Options.** Click this button to show a list of all the columns that can be included on the Game List. Select a column to show it, and clear a check box to hide the column. Click the **Hide Options** button when you're done.

- **Highlight Across Division Games.** Highlight any slots for across-division games.

- **Records per page.** Enter a number to show that number of records on a page.

**Standings**

**How to Access:** Select View → Standings.

The Standings window displays a variety of ranking information for each team in a division, including the number of wins, losses, ties, the number of games back a team is from first place, and the teams' winning percentages.
What's on this Screen

- **Use Multi-Column Sort.** Select this check box to use the multi-column sorting you defined on the Multi Column Sort window (described below). If this check box is not selected, the columns will be sorted in chronological order.

- **Multiple Column Sort.** Click the ![Multi-Column Sort](Image) icon to access the Multi Column sort window, where you can chose columns to sort by and indicate whether the information should be sorted in alphabetical order.

- **Preferences.** Click the ![Preferences](Image) icon to open a window where you can select the columns to display.

- **Save Preferences.** Click the ![Save Preferences](Image) icon to save your defined preferences. The Save Preferences window will show, where you can specify which settings should be retained when the Standings window is loaded in the future.

- **Manage Preferences.** Click the ![Manage Preferences](Image) icon to indicate whether the preferences you specified on the Save Preferences window should display when you load the Standings window.

- **Print.** Click the ![Print](Image) icon to print the contents of the Standings window. When you print, you'll be presented with a list of options, including defining the report title, subtitle, header, and footer.

- **Print to PDF.** Click the ![Print to PDF](Image) icon to export the Standings window as a PDF file. A window will display where you can type in a report title, subtitle, header, and footer.
• **Export to HTML.** Click the (Export to HTML) icon to export your Standings window as an HTML file. Before you export, you'll see a window where you can enter a title for the file and indicate whether to include game results.

• **Export.** Click the (Export) icon to export the Team Balance screen to a variety of formats, including Microsoft Excel and Word. On the window that displays, you can indicate which pages and columns should be included in the exported file.

• **Expand All.** Click the (Plus Sign) icon at the bottom of the screen to expand the divisions.

• **Collapse All.** Click the (Minus Sign) icon at the bottom of the screen to collapse the divisions.

• **Group All.** List the teams together without dividing by division. This can help you see the rankings across divisions more easily rather than having to compare between divisions.

• **Show Playoff Builder.** Clicking this button displays a column of check boxes, allowing you to select the teams to include in a playoff bracket. Once you've selected the teams, click the **Create Playoff Bracket** button. A new Playoff schedule is created and you are brought to the Schedule tab, where you can schedule either a single elimination tournament or a double elimination tournament.

• **Configure Custom Scoring Options.** Click the (Configure Custom Scoring Options) icon to display the following window, where you can specify how points for teams should be counted if you work on a points system, as well as indicate whether across-division games should be included in calculations.
• **Column Options.** Click this button to show a list of all the columns that can be included on the Standings window. Select a column to show it, and clear a check box to hide the column. Click the **Hide Options** button when you're done.

### Show Reschedule List

**How to Access:** Select View → Show Reschedule List.

The Show Reschedule List option opens the Games to Reschedule window, where games that have been added to the reschedule list display.

![Show Reschedule List Window](image)

On this window, you have the option to copy the entire list, remove selected games, or remove all games on the list.

To schedule a selected game for a future timeslot, click the **Schedule Selected Games in Future** button. To make sure it's not assigned to just any old timeslot,
the Reschedule Parameters window will display, with plenty of options to indicate exactly the type of timeslot the game can be rescheduled to.

### Reschedule Parameters

#### Between Games
- **Same Day OK**
- **Limit times per season**
- Leave at least [0] hrs and [1] mins
- **Next Day OK**
- **Custom**
- **Use Weekend Method**
- **Friday Too**

**Date on which to start rescheduling** 2/17/2017
- **Limit Games per Week**
- **Limit Games in a Season**

**Which timeslots can be used besides divisions’ timeslots?**
- **Use unassigned timeslots (no division association)**
- **Use multi-division timeslots**
- **Visitor can play as home away**
- **Use any available venue**

[Submit] [Cancel]

---

**What's on this Screen**

- **Between Games.** This section lets you define limits for how closely together a game can be scheduled to another game. For example, you may coach a little league that is not allowed to play back-to-back games or even games the day after they've played.
  - **Same Day OK.** The teams can play multiple games on the same day. You can then set the max number of games the teams can play in a day.
• **Limit times per season.** Limit the number of times per season that the teams can play multiple games on the same day.

• **Leave at least ___ hrs ___ mins.** Indicate how many hours and minutes should be left between games played on the same day. For example, if you have a 10:00, 11:00, 12:00, and 1:00 slot on Saturday, entering 1 hour here will prevent a team from being scheduled at 10:00 and 11:00. Instead, they will likely be scheduled at 10:00 and 12:00.

• **Next Day OK.** Teams cannot play multiple games on the same day, but can play games on congruent days. For example, a team can play on both Wednesday and Thursday.

• **Custom.** Specify the number of days teams must have between games.

• **Use Weekend Method.** Assuming you have a sufficient number of timeslots to support the pairings, this method attempts to schedule one game during the week and one game during weekend. Select the **Friday Too** check box to indicate Friday should be considered a weekend day.

• **Date on which to start rescheduling.** Select the date on which rescheduling should start. Games are only rescheduled on or after the selected date.

• **Limit Games per Week.** Limit the number of games the teams can play per week.

• **Limit Games in a Season.** Limit the number of games the teams can play per season.

• **Use unassigned timeslots (no division association).** Games can be rescheduled using timeslots with no division associations.

• **Use multi-division timeslots.** Games can be rescheduled using timeslots to which multiple divisions are associated.

• **Visitor can play as home away.** A team can play as the home team at an away venue.

• **Use any available venue.** Indicate that it’s okay to use any venue available for use by the division, and not just the venue associated with the division.
Game Balance

How to Access: Select View → Game Balance.

The Game Balance screen displays statistics on the numbers of games each team has in a variety of counts, including the following:

- Visiting games
- Home games
- Games on each day of the week
- Early, mid-day, and late games
- Practice games
- Across-division games

Note: You can hover your mouse over each column title on the grid to show a tooltip explaining the column.
What's on this Screen

- **Filters panel.** The Filters panel lets you filter out certain divisions, teams, or venues, which can be useful for simplifying the view and allowing you to focus on one schedule at a time.

- **Home.** Access the Home screen.

- **Save Preferences.** Click the (Save Preferences) icon to save your defined preferences. The Save Preferences window will show, where you can specify which settings should be retained when the Game Balance screen is loaded in the future.

- **Print.** Click the (Print) icon to print the Game Balance screen. When you print, you'll be presented with a list of options, including defining the report title, subtitle, header, and footer.

- **Print to PDF.** Click the (Print to PDF) icon to export the Game Balance screen as a PDF file. A window will display where you can type in a report title, subtitle, header, and footer.

- **Export to HTML.** Click the (Export to HTML) icon to export your Game Balance screen as an HTML file. Before you export, you'll see a window where you can enter a title for the file.

- **Export to Word.** Click the (Export to Word) icon to export the Game Balance screen to Microsoft Word. On the window that displays, you can indicate which pages and columns should be included in the exported file.

- **Export.** Click the (Export) icon to export the Game Balance screen to a variety of formats, including Microsoft Excel and CSV. On the window that displays, you can indicate which pages and columns should be included in the exported file.

- **Expand All.** Click the (Plus Sign) icon at the bottom of the screen to expand the divisions.

- **Collapse All.** Click the (Minus Sign) icon at the bottom of the screen to collapse the divisions.

- **Refresh Midpoint Setting.** You can set the "break point" for what is considered an early game and a late game using this option. Enter your break point in the field and click the (Refresh Midpoint Setting) icon to reset the breakpoint. For example, if you enter **4:00 PM**, games scheduled before 4:00 PM are considered early games, and games scheduled after 4:00 PM are considered late games.

- **Game Balance Configuration.** Click the (Game Balance Configuration) icon to access a window where you can specify whether to include practices and across-division games in game balance totals.
• **Refinement Tools.** Clicking this button accesses a variety of options to help you even out the game distribution between teams. The following buttons are available.

  • **Find Early.** Select a team in the grid and click this button to try and automatically find early timeslots that mid or late games can be rescheduled to.

  • **Find Mid.** Select a team in the grid and click this button to try and automatically find mid timeslots that early or late games can be rescheduled to.

  • **Find Late.** Select a team in the grid and click this button to try and automatically find late timeslots that early or mid games can be rescheduled to.

  • **Flip if Possible.** Select two teams in the grid and click this button to try and automatically balance game distribution between two teams.

  • **Hide Tools.** Hide the refinement buttons.

**Game Balance Window**

**How to Access:** Select View → Game Balance Window.

The Game Balance window displays statistics on the numbers of games each team has in a variety of counts, including the following:

  • Visiting games
  • Home games
  • Games on each day of the week
  • Early, mid-day, and late games
  • Practice games
  • Across-division games

**Note:** You can hover your mouse over each column title on the grid to show a tooltip explaining the column.

This window is similar to the Game Balance screen, but can be opened for reference while you're on other screens in the system and also offers a couple of extra options.
What’s on this Screen

- **Expand All.** Click the (Plus Sign) icon at the bottom of the screen to expand the divisions.

- **Collapse All.** Click the (Minus Sign) icon at the bottom of the screen to collapse the divisions.

- **Include Practices in Totals.** Include practice games in the game balance totals.

- **Include Across.** Include across-division games in game balance totals.

- **Division Only.** Show only division games on the grid.

- **Across Only.** Show only across-division games on the grid.

- **Practices Only.** Show only practice games on the grid.

- **Refinement Tools.** Clicking this button accesses a variety of options to help you even out the game distribution between teams. The following buttons are available.

  - **Refresh Midpoint Setting.** You can set the "break point" for what is considered an early game and a late game using this option. Enter your break point in the field and click the (Refresh Midpoint Setting) icon to reset the breakpoint. For example, if you enter 4:00 PM, games scheduled before 4:00 PM are considered early games, and games scheduled after 4:00 PM are considered late games.
- **Find Early.** Select a team in the grid and click this button to try and automatically find early timeslots that mid or late games can be rescheduled to.

- **Find Mid.** Select a team in the grid and click this button to try and automatically find mid timeslots that early or late games can be rescheduled to.

- **Find Late.** Select a team in the grid and click this button to try and automatically find late timeslots that early or mid games can be rescheduled to.

- **Flip if Possible.** Select two teams in the grid and click this button to try and automatically balance game distribution between two teams.

- **Create Pair.** Select two teams and click this button to create a pairing between those teams and send the pairing to the Reschedule List.

- **Create Game.** Select two teams, select an open timeslot on the Master Calendar screen or Timeslot Calendar screen, and click this button to create a game between the teams using a that timeslot.

- **Hide Tools.** Hide the refinement buttons.

- **Close.** Close the Game Balance window.

---

**Team Balance**

**How to Access:** Select View → Team Balance.

The Team Balance screen displays statistics on the teams each team plays as the visiting team or home team.
What's on this Screen

- **Filters panel.** The Filters panel lets you filter out certain divisions, teams, or venues, which can be useful for simplifying the view and allowing you to focus on one schedule at a time.

- **Home.** Access the Home screen.

- **Use Multi-Column Sort.** Select this check box to use the multi-column sorting you defined on the Multi Column Sort window (described below). If this check box is not selected, the columns will be sorted in chronological order.

- **Multiple Column Sort.** Click the (Multiple Column Sort) icon to access the Multi Column sort window, where you can chose columns to sort by and indicate whether the information should be sorted in alphabetical order.

- **Preferences.** Click the (Preferences) icon to open a window where you can select the columns to display.

- **Save Preferences.** Click the (Save Preferences) icon to save your defined preferences. The Save Preferences window will show, where you can specify which settings should be retained when the Team Balance screen is loaded in the future.

- **Manage Preferences.** Click the (Manage Preferences) icon to indicate whether the preferences you specified on the Save Preferences window should display when you load the Team Balance screen.

- **Print.** Click the (Print) icon to print the Team Balance screen. When you print, you'll be presented with a list of options, including defining the report title, subtitle, header, and footer.

- **Print to PDF.** Click the (Print to PDF) icon to export the Team Balance screen as a PDF file. A window will display where you can type in a report title, subtitle, header, and footer.

- **Export to HTML.** Click the (Export to HTML) icon to export your Team Balance screen as an HTML file. Before you export, you'll see a window where you can enter a title for the file.

- **Export.** Click the (Export) icon to export the Team Balance screen to a variety of formats, including Microsoft Excel and Word. On the window that displays, you can indicate which pages and columns should be included in the exported file.

- **Expand All.** Click the (Plus Sign) icon at the bottom of the screen to expand the divisions.

- **Collapse All.** Click the (Minus Sign) icon at the bottom of the screen to collapse the divisions.
Team Balance Window

How to Access: Select View → Team Balance Window.

The Team Balance window displays statistics on the teams each team plays as the visiting team or home team. This window is similar to the Team Balance screen, but can be opened for reference while you're on other screens in the system.

What's on this Screen

- **Division Filters.** You can filter out certain divisions to simplify the view and allow you to focus on one at a time.
- **Timeslot View.** If only one division is selected in the Division Filters box, you can choose whether to display games for all schedules or for just the current division's schedule.
- **Refresh.** Refresh the grid to show the most current counts.
- **Expand All.** Click the (Plus Sign) icon at the bottom of the screen to expand the divisions.
- **Collapse All.** Click the (Minus Sign) icon at the bottom of the screen to collapse the divisions.
- **Close.** Close the Team Balance window.
**Venue Balance**

**How to Access:** Select View → Venue Balance.

The Venue Balance screen displays statistics on the number of times each team plays at each venue.

**What’s on this Screen**

- **Filters panel.** The Filters panel lets you filter out certain divisions, teams, or venues, which can be useful for simplifying the view and allowing you to focus on one schedule at a time.

- **Home.** Access the Home screen.

- **Use Multi-Column Sort.** Select this check box to use the multi-column sorting you defined on the Multi Column Sort window (described below). If this check box is not selected, the columns will be sorted in chronological order.

- **Multiple Column Sort.** Click the ▼ (Multiple Column Sort) icon to access the Multi Column sort window, where you can chose columns to sort by and indicate whether the information should be sorted in alphabetical order.
• **Preferences.** Click the (Preferences) icon to open a window where you can select the columns to display.

• **Save Preferences.** Click the (Save Preferences) icon to save your defined preferences. The Save Preferences window will show, where you can specify which settings should be retained when the Venue Balance screen is loaded in the future.

• **Manage Preferences.** Click the (Manage Preferences) icon to indicate whether the preferences you specified on the Save Preferences window should display when you load the Venue Balance screen.

• **Print.** Click the (Print) icon to print the Venue Balance screen. When you print, you'll be presented with a list of options, including defining the report title, subtitle, header, and footer.

• **Print to PDF.** Click the (Print to PDF) icon to export the Venue Balance screen as a PDF file. A window will display where you can type in a report title, subtitle, header, and footer.

• **Export to HTML.** Click the (Export to HTML) icon to export your Venue Balance screen as an HTML file. Before you export, you'll see a window where you can enter a title for the file.

• **Export.** Click the (Export) icon to export the Venue Balance screen to a variety of formats, including Microsoft Excel and Word. On the window that displays, you can indicate which pages and columns should be included in the exported file.

• **Expand All.** Click the (Plus Sign) icon at the bottom of the screen to expand the divisions.

• **Collapse All.** Click the (Minus Sign) icon at the bottom of the screen to collapse the divisions.

---

### Venue Balance Window

**How to Access:** Select View → Venue Balance Window.

The Venue Balance window displays statistics on the number of times each team plays at each venue. This window is similar to the Venue Balance screen, but can be opened for reference while you’re on other screens in the system.
What's on this Screen

- **Expand All.** Click the (Plus Sign) icon at the bottom of the screen to expand the divisions.
- **Collapse All.** Click the (Minus Sign) icon at the bottom of the screen to collapse the divisions.
- **Refresh.** Refresh the grid to show the most current counts.
- **Close.** Close the Venue Balance window.

Available Unscheduled Timeslots

**How to Access:** Select View → Available Unscheduled Timeslots.

This window shows you various counts for available timeslots for each division, team, and venue, including timeslots that are unassigned. This option can be useful for identifying why a schedule might not be completing or might not be as even as you'd hoped. For example, you might have a team that isn't getting as many games scheduled as the others. Using this option, you could see that team also doesn't have as many home timeslots, leading you to your issue and allowing you to correct it.
### What's on this Screen

- **Total Timeslots.** Displays the total number of timeslots that are unscheduled across all divisions and venues.

- **Single Division.** Displays the number of timeslots that are unscheduled but are assigned to a certain division.

- **Multi.** Displays the number of timeslots that are unscheduled but are assigned to multiple divisions.

- **Unassigned.** Displays the number of timeslots that are unscheduled and are not assigned to any division.

- **Division.** Select whether to show counts for all divisions or a particular division.

- **Expand All.** Click the (Plus Sign) icon at the bottom of the screen to expand the divisions. This option is available for both the main grid and the Team Venues grid.

- **Collapse All.** Click the (Minus Sign) icon at the bottom of the screen to collapse the divisions. This option is available for both the main grid and the Team Venues grid.

- **Home Timeslots Detail.** Click this button to run the Available Home Timeslots report, which shows only remaining available home timeslots for a division. This report doesn't include timeslots that are already scheduled and used by other divisions.

  A window will display where you can select the division to include in the report. Click the **View** button to run the report, which will display as a separate in-system window.
• **Hide Home Venues.** Hide the Team Venues box. You can click the **Show Home Venues** button to redisplay the box.

• **Close.** Close the Available Unscheduled Timeslots window.

---

**Show Last Schedule Problem Log**

**How to Access:** Select View → Show Last Schedule Problem Log.

When you automatically create a schedule, conflicts can sometimes occur that cause the schedule to be incomplete. For example, perhaps there were too few timeslots to accommodate the number of rounds you requested. Using this option, you can review a team play analysis report that may help you identify why a schedule wasn't completed. This report functions as an activity log for the scheduling process, in a sense helping you see how the system was "thinking" when scheduling.

![Team Play Analysis Report]

You can add your own notes directly into the window and copy the contents of the window by clicking the **Copy to Clipboard** button.
Home

**How to Access:** Select View → Home.

You can also press the Ctrl+H hot key combo or click the Home button on a number of screens such as the Master Calendar or the Game List.

The Home screen, as indicated by the cleverly apt title, is your main hub of activity in Diamond Scheduler, especially when you're first setting up. This is the screen that you'll automatically be on when you start up Diamond Scheduler. You'll use this screen to enter all of your information that Diamond Scheduler will use to create your schedules, including your divisions, teams, and venues. This screen also contains the tab for specifying your scheduling options and making the scheduling magic happen.

We'll go into each tab on this screen in good detail, but first let's note the League Browser panel, which lets you quickly jump to any division, venue, person, or schedule you've already created. This panel is available on each tab of the Home screen. Simply click a heading or a specific item to access the corresponding tab or record. For example, you can click Venues to access the Venues tab, or you can click Bluejays to jump to the Bluejays record on the Teams tab.
The Divisions tab is where you'll enter, edit, or delete your divisions for a league.

This screen is pretty simple. You'll see the division name, the abbreviation, a custom code if you've entered one, and any notes. You can select a specific division to work with in the **Division Name** field.

On this screen, you can do the following things.

- Add a Division
- Edit a Division
- Delete a Division
Add a Division

To add a new division, click the **New** button. You'll get a division entry screen, where you can enter all the information you'll need to set up a division. When you're done, click the **Done** button.

What's on this Screen

- **Division Name.** Enter a name for the division. This field is required.
- **Abbreviation.** Enter an abbreviation that can be used on calendar views. This field is also required.
• **Custom Code.** If you're integrating Diamond Scheduler with third-party league hosting sites, you can use this field to enter information such as the division ID for the site that need to be preserved and exported when you're ready to upload your schedule.

• **Out-of-League.** If you have a handful of out-of-league games, possibly with a traveling team that is not in your league, you can create a generic division for those teams so they can be scheduled without being counted in standings. Select this check box to mark the division as out-of-league.

• **Across Divisions.** Once your league file has more than one division, you'll be able to select this check box, which will indicate that the division is an "across-division" division that should be used in across-division schedules using existing teams.

**Edit a Division**

Click the **Edit** button to edit a division using basically the same process as adding a division, only you're modifying information that you've already entered.

**Delete a Division**

Deleting a division will also delete and teams and schedules associated with the division. Consider carefully before clicking the **Delete** button.

**Teams Tab**

The Teams tab is where you'll enter your teams in each division. On this tab, you can associate coaches and players to the teams, define time and travel constraints, and also enter special request games.
On this screen, you can do the following things.

- Add a Team
- Edit a Team
- Delete a Team
- Define Time Constraints
- Define Travel Constraints
- Add a Special Request Game

Add a Team

To add a team, click the **New** button. You'll see a team entry screen, where you can enter the following information. When you're done, click the **Done** button.
What's on this Screen

- **Division Name.** Select the division the team is being added to.
- **Team Name.** Enter a name for the team. This field is required.
- **Abbreviation.** Enter an abbreviation to use on calendar views. This field is required.
- **Custom Code.** If you're integrating Diamond Scheduler with third-party league hosting sites, you can use this field to enter information such as the team ID for the site that need to be preserved and exported when you're ready to upload your schedule.
- **Coaches.** Drag and drop a coach from the Coaches box to associate the coach with the team. You add coaches on the People tab. When you're done, click the (Accept Selections) icon. If you need to add a coach, click
the (Add Coach) icon. To delete a coach, select the coach and click the (Delete) icon.

Associating coaches with a team can come in handy when scheduling if any coaches lead more than one team. This will help prevent teams being scheduled to play against each other if the same coach leads both teams.

- **Coaches Box.** Coaches available to associate with the team display here. If a coach is already associated, you'll see a green checkmark next to the name. If you need to add a coach, click the (Add a new person) icon. A small window to add a coach's first name and last name displays.

- **Players.** Drag and drop a player from the Players box to associate the player with the team. You can add players on the People tab. When you're done, click the (Accept Selections) icon. If you need to add a player, click the (Add Player) icon. To delete a player, select the player and click the (Delete) icon.

Associating players with a team can come in handy when scheduling if any players are on more than one team. This will help prevent teams being scheduled to play against each other if the same player is on both teams.

- **Players Box.** Players available to associate with the team display here. If a player is already associated, you'll see a green checkmark next to the name. If you need to add a player, click the (Add a new person) icon. A small window to add a player's first name and last name displays.

- **No Play Teams.** For whatever reason, your league may have an instance where two teams simply should not play each other, like if there have been troubles between two teams in the past. You can click this button to specify which teams the currently displayed team should never be scheduled against.

- **No Play Venues.** You can also specify venues that a team should never be scheduled at, such as when you have a coach who needs to use a wheelchair and therefore cannot play at a venue where accessibility is an issue. Click this button to specify those venues.

**Edit a Team**

Click the Edit button to edit a team using basically the same process as adding a team, only you're modifying information that you've already entered.
Delete a Team

Click the **Delete** button to delete the currently displayed team.

Define Time Constraints

You can define a time constraint if there are days or times in the week that a team cannot play. You can also specify black-out dates for particular teams. To set up time constraints, click the **Time Constraints** button.

**Note**: If a division’s schedule is already locked, changes you make to time constraints cannot be applied to already scheduled games.
What's on this Screen

• **Team Name.** Select the team to add a time constraint for.

• **Constraint Type.** Select the type of constraint that you’re adding, which includes the following.
  
  • **Weekly Constraints.** Constraints that should be applied every week regardless of venue.
  
  • **Home Venue Constraints.** Constraints that are applied to the only the team's home venue.
  
  • **Specific Venues Constraints.** Constraints that are applied to other venues.

• **Recurring Time Constraints.** In this box, you can specify that the team cannot play on an entire day by selecting the All Day check box. Or you can define specific time restrictions using the Before/After and Not Before/Not After fields. For example, if a team cannot play on Sundays before 12:00 PM or after 5:00 PM, select those times in the Before and After fields in the row for Sunday. If a

  If you've selected Specific Venues Constraints in the Constraint Type field, additional icons display that let you view the venues affected by the time constraint on a certain day, as well as delete all constraints for a certain day of the week.

• **Venue Use Constraints.** If you've selected Specific Venues Constraints in the Constraint Type field, you can restrict certain teams from using certain venues by clicking the 🏡 (Venue Use Constraints) icon. The following window displays.
On this window, you'll create a constraint. You can select a specific team in the **Team** field, indicate the constraint should apply to all teams in the division, or select a group of teams the constraint should apply to. In addition, you can specify how many times per season or per week the teams should be allowed to play at the venue.

- **Apply to all teams.** Apply the settings in the Recurring Time Constraints box to all teams.

- **Apply to some teams.** Apply the settings in the Recurring Time Constraints box to some teams. When you select this check box, a window will display where you can pick the teams to apply the constraints to. If you need to change which teams are included later, you can click the (Select teams for settings) icon to access that window again.
• **Delete Recurring.** Delete all recurring time constraints for the currently selected team.

• **Specific Dates Calendar.** Use this calendar to select specific dates that teams have restrictions on (as opposed to general days of the week). If a date has an all-day exclusion, it shows in red. If a date has a time constraint, it shows in orange.

• **All Day Exclusion.** Select this check box to exclude the entire selected day from being scheduled.

• **Before/After.** Enter a time before which and after which the team cannot play on the selected date.

• **Delete Selected Dates.** Delete the selected date constraints.

• **Not Before/Not After.** These fields function much the same as the Before and After fields, but can also be used if the logic works out for you more easily. For instance, you may know that a team cannot play until 4:00 PM and think of that as "not before 4:00 PM" rather than "after 4:00 PM". These fields just allow for differences in thinking about windows of time.

• **Delete All Dates.** Delete all season date constraints for the currently displayed team.

• **Apply to All Teams.** Apply the defined date restrictions to all teams.

• **Apply to Some Teams.** Apply the settings in the Specific Dates box to some teams. When you select this check box, a window will display where you can pick the teams to apply the constraints to. If you need to change which teams are included later, you can click the (Select teams for settings) icon to access that window again.

• **Save and Close.** Save your settings and close the Time Constraints subscreen.

• **Save.** Save your settings.

• **Close.** Close the Time Constraints subscreen without saving changes.

---

**Define Travel Constraints**

You can only define travel constraints if you've entered a location for your venues on the Venues tab. This can be helpful for preventing teams from being scheduled for venues that are farther away than they can reasonably travel. For example, you may not want a team to have to travel as far on weekdays as they can on weekends. Or you may not want a team to have to travel over a certain number of miles between games on the same day.
To define travel constraints, click the Travel Constraints button.

**What’s on this Screen**

- **Team Name.** Select the team to add the travel constraint for.
- **Previous Days.** When limiting the distance that a team can travel from the previous game, the system needs to know how many days to search backwards for a previous game. You can enter from 0 (same day) to 3 (3 days previous).
- **From Home.** Enter the number of miles over which a team cannot travel from their home venue on a certain day.
- **From Previous Game.** Enter the number of miles over which a team cannot travel from their previous game. This restriction will be based on the number of days you entered in the Previous Days field.
- **Apply to All Teams.** Apply the travel constraints to all teams.
• **Apply to Some Teams.** Apply the travel constraints to some teams. When you select this check box, a window will display where you can pick the teams to apply the constraints to. If you need to change which teams are included later, you can click the (Select teams for settings) icon to access that window again.

• **Show Distance Grid of Division Home Venues.** Show the number of miles between each of your venues. This window will only display if you’ve used the Locate feature on the Venues tab to get the exact coordinates of your venues.

• **Save and Close.** Save your settings and close the Travel Constraints subscreen.

• **Apply.** Apply the settings.

• **Cancel.** Close the Travel Constraints subscreen without saving your changes.

---

**Add a Special Request Game**

Do you have a league matchup in your division that is traditionally included on a particular day — like how the Cowboys always play at home on Thanksgiving? Click the **Special Requests** button to specify a specific date and request that a team plays as either home or away in a number of matchup situations.
What's on this Screen

- **Team Name.** Select the team you're setting up the special request for.

- **Bind Teams.** When you click this button, you'll be presented with a separate screen where you can indicate teams that should always travel together and venues that are in the same area, which can be useful for scheduling purposes.

  For example, say you coach a high school basketball league and the girls team and boys team for each school always travel together to play the same high school. Pairing up teams this way can help make sure these teams are always playing at the same venue on the same day.

- **Calendar.** Use the calendar to select the date for the special request game. The current date is highlighted in orange, and the dates of any existing special request games are highlighted in yellow.

- **Game Types.** The following option buttons let you select the type of game for the special request.
  - **Home Game.** The team should play at home.
  - **Away Game.** The team should play as the away team.
  - **Home with Specific Team.** The team should play at home with a specific team. When you select this option button, a team list displays to the right, allowing you to select the specific team they'll play.
  - **Home Double Header.** The team should play at home for a double header.
  - **DH Home with Specific Team.** The team should play at home for a double header with a specific team. When you select this option button, a team list displays to the right, allowing you to select the specific team they'll play.
  - **As Home at Neutral Venue.** The team should play at home, but at a neutral venue. When you select this option button, a field displays below where you can pick the venue to use, and the team list displays to the right, allowing you to the select the team they'll play.

- **Add Request.** Add the requested game to the calendar.

- **Game List Box.** Special request games for the selected team display.

- **Ignore Time and Travel Constraints for All Special Requests.** When this option is enabled, all time and travel constraints defined for the team are ignored whenever special request games for that team are created.
**Note:** You can specify that time and travel constraints should be ignored for any request for any team at all times by enabling the Ignore Time and Travel Constraints for Special Requests option in the Edit menu.

- **Close Settings.** Close the Special Requests subscreen.

### Venues Tab

The Venues tab is where you’ll enter all the information about your venue locations, including the address and the home teams. You can also set a priority for each venue and have the system locate the exact coordinates of the venue, which are used when creating travel constraints.

### What's on this Screen

- **Venue Name.** Enter the venue name. This field is required.
- **Abbreviation.** Enter an abbreviation to use on calendar views. This field is required.
- **Custom Code.** If you're integrating Diamond Scheduler with third-party league hosting sites, you can use this field to enter information such as the
division ID for the site that need to be preserved and exported when you’re ready to upload your schedule.

- **Address 1.** The first line of the address.
- **Address 2.** The second line of the address.
- **City.** The venue’s city.
- **State.** The venue’s state.
- **Zip.** The venue’s ZIP code.
- **Phone.** The venue's phone number.
- **Home Teams Box.** Displays the home teams associated with the venue.
- **Locate.** Click this button to use the Locate feature to obtain the coordinates of the venue, which are used when creating travel constraints. A map view will open, which has many of the same features as most online mapping services, such as Google Maps.

Click the exact location of the venue (indicated by a red dot) and then click the **Save Location** button to save the coordinates.

**Note:** Entering information in the **Address 1** field, **City** field, **State** field, and **Zip** field will help increase the accuracy of the Locate feature. In addition, using the Satellite view is often helpful in pinpointing the venue.

Once you've used the Locate feature, the latitude coordinate of the venue displays in the field next to this button.

- **View.** Click this button to view the location in Google Maps. Once you've used the Locate feature, the longitude coordinate of the venue displays in the field next to this button.
- **Copy.** Copy the Google Maps URL for the venue for use in other documents. The link displays in the field next to this button.
- **Add Home Team.** Click the **(Add Home Team)** button to display the Select Home Teams Box, where you can add home teams to the venue.
- **Delete Home Team.** Select a team in the Home Teams Box and click the **(Delete)** icon to remove the team from the venue.
- **Show Division Codes.** Select this check box to show the division abbreviations of the teams in the Home Teams Box.
- **Venue Timeslots.** The number of timeslots associated with the selected venue displays.
- **Timeslots.** Click this button to access the **Timeslot Calendar**, where you can identify the timeslots that can be used for this venue.
• **Import Timeslots.** You can import timeslots from another venue or from a CSV file.

If you want to add timeslots from another venue, the Clone from Venue window displays, where you can choose the venue to clone from and indicate whether the timeslots should keep their division associations.

If you want to import timeslots from a CSV file, the Import from File window will display, where you can specify the date, time, and CSV line formats to import.

• **Display Distance Grid.** Show the number of miles between each of your venues.

• **New.** Add a new venue.

• **Clone.** Clone information from an existing venue. This feature can be useful when you're adding a venue record for each baseball diamond at the same park, for example. You'll also be prompted as to whether you want to close the timeslots for the venue.

• **Edit.** Edit the selected venue.

• **Delete.** Delete the selected venue. You'll be prompted to confirm the deletion.

• **Priority.** You can give the venues rankings for desirability. **+3** is the best ranking and **-3** is worst ranking. This setting is used if you employ venue priorities during scheduling to use the best venues first.

When you add a new venue, clone a venue, or edit an existing venue, the following additional options display.

• **Select Home Teams Box.** Teams available to associate with the venue display here. If a team is already associated, you'll see a green checkmark next to the name.

• **Accept Selections.** When you're done associating teams to the venue, click the (Accept Selections) icon.

• **Add All.** Add all the teams in the Select Home Teams Box to the venue.

• **Quick add for new team.** If you need to add a team, click the (Quick add for new team) icon. A small window to add the team's division, name, and abbreviation displays.

• **Division.** Show only teams from a certain division. Or select All Divisions to show all teams.
- **Lock.** Click the 🗝️ (Lock) icon to lock the selected division picked in the Division field. This selection will automatically display when you reaccess the Venues tab.

- **Cancel.** Cancel the addition, cloning, or editing of the venue.

**People Tab**

The People tab can be used to enter records for players, coaches, officials, and other staff on your teams or in your divisions. While person records aren’t necessary for scheduling a league, this tab can come in handy if you have people who are associated with more than one team — for example, if you have coaches that lead more than one team, players that play on more than one team, or officials who referee for multiple divisions. In addition, you can add contact information for coaches, which can be printed out or included on other reports for reference.
What's on this Screen

- **Person.** Select the person record to show.
- **First Name.** Enter the person's first name.
- **Last Name.** Enter the person's last name.
- **Roles.** The following default role types are available for you to define what type of person you're adding. You can define your own labels by clicking the (Labels Settings) icon. In addition, roles are not mutually exclusive, so a person could be both a coach and a player.
  - **Player.** Indicate the person is a player.
  - **Coach.** Indicate the person is a coach.
  - **Official.** Indicate the person is an official, such as a referee.
  - **Staff.** Indicate the person is a staff member, such as an equipment manager.
- **Labels to Use.** Click the (Labels Settings) icon to show fields that you can use to define the labels for the Roles check boxes. For example, you may be scheduling a swim league and want the **Player** check box to display as the **Swimmer** check box. Simply type **Swimmer** in the **Participant** field and click the **Save** button. A participant and coach type record are typically needed, but you can customize the last two check boxes.
- **Notes.** Add notes for the person.
- **Address.** Click the (Add Address) icon to display fields where you can enter the person's address. Click the icon again to add another address.
- **Phone.** Click the (Add Phone) icon to display fields where you can enter the person's phone number. Click the icon again to add another number.
- **Email.** Click the (Add Email) icon to display fields where you can enter the person's email address. Click the icon again to add another email address.
Schedule Tab

This is it. The Schedule tab is the reason you've entered tons of records' worth of information and what Diamond Scheduler was made for — to create the schedules for your league! We'll take a look at the features of this tab based on the two main types of schedules you can make: Tournament and League. But before we go into details, let's review the different types of schedules.

- **Elimination.** Elimination style schedules are used for tournaments, where sets of teams play against each other until one team is left as the ultimate winner. The system can schedule for both single elimination schedules (eliminating teams upon their first loss) or double-elimination schedules (eliminating teams after they have lost two games).

- **Round Robin.** Round Robin is the most common type of league schedule where each team plays every other team a certain number of times during the season.

- **Across-Division.** Used for inter-league or across-division scheduling, this type of schedule results in all teams from one league playing all teams in another league, but not teams from their same league. This is most often combined with a regular Round Robin schedule for the rest of the season.
• **Practice.** Practice schedules are simply that — games set up for practicing, which don't count in results or other counts.

• **Manual.** You can ignore the powerful automatic scheduling capabilities of Diamond Scheduler and manually create games yourself. This is useful if you want to ensure one game is played on a particular date or if you've already started the season before scheduling and you need to input the games that have already been played. Once you input manual games, you would typically right-click on the calendar and choose the Lock All Scheduled Games option.

---

**Tournament Subscreen**

The Tournament subscreen displays when you choose to make a Single Elimination schedule or a Double Elimination schedule. It is important to note that some options are required (indicated by a red asterisk), but that the fewer choices you make, the more likely it is that your schedule will work out, as there will be fewer limitations for the system to adhere to.
What's on this Screen

- **Division Name.** Select the division to create the schedule for.
- **Schedule.** Select the schedule to create. The first schedule you make is automatically named after the division, but you can edit the name by clicking the (Edit current schedule's name) icon.
- **Create an additional schedule for this division.** Click the (Create an additional schedule for this division) icon to add another schedule for the division. For example, you may want to make both a practice schedule and a league schedule for the same division.
- **Edit current schedule's name.** Click the (Edit current schedule's name) icon to change the name of the currently selected schedule. On the window that displays, you can also enter a custom code for the schedule.
- **Schedule Settings.** In this section, you can indicate how teams should be allotted within the schedule.
  - **Rank order teams (best on top).** Select this check box to rank the teams in order, which is used for seeding. Drag and drop the teams in the box below, from the best at the top of the list to the worst at the bottom of the list. You can also have the system automatically rank them based on game scores by clicking the Base Rankings on Division Standings button.
  - **Use Team Placeholders (TBD).** Create a schedule without using actual teams (placeholders) to make a "to be determined" schedule.
  - **Seedings and Timeslots only.** Create a schedule that only lists seed numbers and timeslots on the bracket.
- **Timeslot Settings.** This section is used to indicate which types of timeslots can be used during scheduling. You can select multiple options in this section.
  - **Use Current Division's Timeslots.** Use the timeslots assigned to the division selected in the Division Name field. This option is always selected.
  - **Unassigned Slots.** Use timeslots that don't have division assignments. You can also select the Proportional check box to indicate that unassigned slots should be used proportionally to timeslots assigned to the division, which can be useful to make sure one division schedule isn't using all of the unassigned timeslots before you can schedule another division.
  - **Multi-Division Slots.** Use timeslots that are associated with multiple divisions. You can also select the Proportional check box to indicate that multi-division slots should be used proportionally to timeslots.
assigned to the division, which can be useful to make sure one division schedule isn't using all of the multi-division timeslots before you can schedule another division.

- **Use any available venue.** Indicate that it's okay to use any venue available for use by the division, and not just the venue associated with the division.

- **Visitor can be home at away venue.** Indicate that teams can play as home teams even in an away venue. Click the (Set Teams) icon to pick the teams that can play as home teams at away venues.

- **Between Games.** This section lets you define limits for how closely together games for teams can be scheduled. For example, you may coach a little league that is not allowed to play back-to-back games or even games the day after they've played.
  - **Same Day OK.** Teams can play multiple games on the same day. You can then set the max number of games a team can play in a day.
  - **Limit times per season.** Limit the number of times per season that a team can play multiple games on the same day.
  - **Leave at least __ hrs __ mins.** Indicate how many hours and minutes should be left between games played on the same day. For example, if you have a 10:00, 11:00, 12:00, and 1:00 slot on Saturday, entering 1 hour here will prevent a team from being scheduled at 10:00 and 11:00. Instead, they will likely be scheduled at 10:00 and 12:00.
  - **Next Day OK.** Teams cannot play multiple games on the same day, but can play games on congruent days. For example, a team can play on both Wednesday and Thursday.
  - **Custom.** Specify the number of days teams must have between games.

- **Schedule Time Frame.** You may want to schedule only a partial season. For instance, you might want to schedule your across-division games in the middle of the schedule. Click the **Choose Date Range** button to show a calendar where you can select your date range. Only timeslots within that range are then used when scheduling.

- **Pairing Type.** Select the types of pairings that should be made in the tournament.
  - **Best-Worst.** Seedings are based on the best team playing the worst team.
  - **Balanced.** Seedings are spread between more similarly matched teams to produce a tournament where underdogs are more likely to have a chance at winning.
• **Available Times.** The number of available timeslots based on your selections displays.

• **Needed.** The number of timeslots needed to make the schedule displays based on your selections. If the number is in red, it means you don’t have enough timeslots.

• **Return to Choices.** Return to the main Schedule tab screen where you can choose the type of schedule to make.

• **Schedule Now.** Click this button to create the schedule! Once you create a tournament schedule, the bracket will display on screen. You can print the bracket and also customize the information that displays, such as whether bye games, game numbers, or team abbreviations should be included. You can also add a name for the tournament to use in reports.

**League Subscreen**

The League subscreen displays when you choose to make a Round Robin schedule, Across-Division schedule, or Practice schedule. It is important to note that some options are required (indicated by a red asterisk), but that the fewer choices you make, the more likely it is that your schedule will work out, as there will be fewer limitations for the system to adhere to.
What's on this Screen

- **Division Name.** Select the division to create the schedule for.
- **Schedule.** Select the schedule to create. The first schedule you make is automatically named after the division, but you can edit the name by clicking the (Edit current schedule's name) icon.
- **Create an additional schedule for this division.** Click the (Create an additional schedule for this division) icon to add another schedule for the division. For example, you may want to make both a practice schedule and a league schedule for the same division.
- **Create an additional schedule for this division.** Click the (Create an additional schedule for this division) icon to add another schedule for the division. For example, you may want to make both a practice schedule and a league schedule for the same division.
- **Edit current schedule's name.** Click the (Edit current schedule's name) icon to change the name of the currently selected schedule. On the window that displays, you can also enter a custom code for the schedule.
- **Schedule Settings.** In this section, you can indicate how teams should be allotted within the schedule. There's a Basic View and an Advanced View to let you see just the most common settings or all of the possible settings.
  - **Normal Pairs.** Create a typical Round Robin schedule where each team plays every other team before the rotation begins again.
  - **Back-to-Back.** Create a schedule where double header games are scheduled between the same teams.
  - **Days Before Rematches.** The number of days that must pass for a pair of teams to replay each other.
  - **Max Team Games per Week.** The max number of games a team can play per week.
  - **Max Team Games for Season.** The max number games a team can play per season.
  - **Use Venue Priorities.** Use the venue priorities you defined on the Venues tab. If this isn't selected, venues are evenly used across the schedule. Click the (Venue Configuration) icon to access a window where you can indicate whether the best venues should be used first or whether venue priorities should be evenly distributed (for instance, so one team does not end up always playing at the best venue and another always plays at the worst). You can also exclude venues from being used for the schedule.
  - **Balance Early/Late.** If you have early and late timeslots, use this setting to distribute early and late games relatively evenly across
teams. You can define the "break point" between early and late games in the field that displays when you select this check box.

For example, if you have games running from 9:00 AM to 9:00 PM, you can enter something like 3:00 PM to indicate that any slots before 3:00 should be considered early and any games after should be considered late.

You can also click the (Configure Tolerance) icon to play with the tolerance level on this setting, as well as prevent runs where a team has multiple early or late games in a row.

- **Encourage Balance of Days Used.** Attempt to even out the balance of days in the week teams are scheduled for. Click the (Configure Tolerance) icon to adjust the tolerance level on this setting. You can even enter a custom tolerance level.

- **Rotate starting team by.** At times, because of odd venue availability, it is worth a try mixing up the rotation matrix a bit to see if you can find a solution for a schedule that isn't working out. For example, let's say the default first game is between Team 1 and Team 6. Rotating the starting team by 1 would make the first game a matchup between Team 2 and Team 6.

- **Max Division Games/Day.** The maximum number of teams in the division that can be scheduled per day.

- **Max Division Games/Week.** The maximum number of teams in the division that can be scheduled per week.

- **Ignore Home/Away Distribution.** If home and away designations are not important in your sport, you can select this check box to make finding scheduling solutions a bit easier.

- **Try Random Pairings.** This option can be used to rotate pairings, which can help mix up scheduling in situations where there are limited timeslots. For example, suppose you have a base rotation of teams 1 v 10, 2 v 9, 3 v 8, 4 v 7, and 5 v 6. When you select this option, the rotation becomes 10 v 1, 9 v 2, 8 v 3, 7 v 4, and 6 v 5, and continues to rotate until all pairings are tried.

- **Flip Home/Away in Pairings.** Switch all default pairings such that the home teams become the visiting teams during the pairings process.

- **Use imported pairings.** This option will be enabled if you’ve used the Pairings Import window to import pairings from a previous schedule to indicate that you want to incorporate those pairings when scheduling.
• **Timeslots to Use.** This section is used to indicate which types of timeslots can be used during scheduling. You can select multiple options in this section.
  
  • **Use Current Division's Timeslots.** Use the timeslots assigned to the division selected in the **Division Name** field. This option is always selected.
  
  • **Unassigned Slots.** Use timeslots that don't have division assignments. You can also select the **Proportional** check box to indicate that unassigned slots should be used proportionally to timeslots assigned to the division, which can be useful to make sure one division schedule isn't using all of the unassigned timeslots before you can schedule another division.
  
  • **Multi-Division Slots.** Use timeslots that are associated with multiple divisions. You can also select the **Proportional** check box to indicate that multi-division slots should be used proportionally to timeslots assigned to the division, which can be useful to make sure one division schedule isn't using all of the multi-division timeslots before you can schedule another division.
  
  • **Use any available venue.** Indicate that it's okay to use any venue available for use by the division, and not just the venue associated with the division.
  
  • **Use Practice Only Timeslots.** Indicate that it's okay to use timeslots that have been marked as practice timeslots.
  
  • **Visitor can be home at away venue.** Indicate that teams can play as home teams even in an away venue. Click the (Set Teams) icon to pick the teams that can play as home teams at away venues.
  
  • **Between Games.** This section lets you define limits for how closely together games for teams can be scheduled. For example, you may coach a little league that is not allowed to play back-to-back games or even games the day after they've played.
    
    • **Same Day OK.** Teams can play multiple games on the same day. You can then set the max number of games a team can play in a day. Click the (Configuration) icon to show a window where you can indicate that Diamond Scheduler should attempt to keep teams with multiple games in the same day at the same venue for that day.
    
    • **Limit times per season.** Limit the number of times per season that a team can play multiple games on the same day.
    
    • **Leave at least ___ hrs ___ mins.** Indicate how many hours and minutes should be left between games played on the same day. For example, if you have a 10:00, 11:00, 12:00, and 1:00 slot on Saturday, entering 1 hour here will prevent a team from being
scheduled at 10:00 and 11:00. Instead, they will likely be scheduled at 10:00 and 12:00.

- **Next Day OK.** Teams cannot play multiple games on the same day, but can play games on congruent days. For example, a team can play on both Wednesday and Thursday.

- **Custom.** Specify the number of days teams must have between games.

- **Use Weekend Method.** Assuming you have a sufficient number of timeslots to support the pairings, this method attempts to schedule one game during the week and one game during weekend. Select the **Friday Too** check box to indicate Friday should be considered a weekend day.

- **Spread Games Out Across Season.** Attempt to spread games for teams out across the season as much as possible. For example, if all teams play 10 games, it's not very cool for all ten of one team's games to be scheduled within the first two weeks of a ten-week season.

- **Schedule Time Frame.** You may want to schedule only a partial season. For instance, you might want to schedule your across-division games in the middle of the schedule. Click the **Choose Date Range** button to show a calendar where you can select your date range. Only timeslots within that range are then used when scheduling.

- **Games to Play.** Define the number of games each team should play.
  - **Rounds.** Specify the number of rounds each team should play with every other team. You can click the (Calculate) icon to have Diamond Scheduler automatically suggest a number of rounds based on the number of available timeslots. Or you can click the (Timeslot Calculator) icon to open the Timeslot Calculator.
  - **Games __ team/week.** Specify the number of games each team should play per week.
  - **Games __ team/season.** Specify the number of games each team should play per season.
  - **Available Times.** The number of available timeslots based on your selections displays.
  - **Needed.** The number of timeslots needed to make the schedule displays based on your selections. If the number is in red, it means you don't have enough timeslots.

- **Return to Choices.** Return to the main Schedule tab screen where you can choose the type of schedule to make.
- **Schedule Now.** Click this button to create the schedule! Once the schedule is created, you’ll see a screen that allows you to access the Master Calendar screen, the Game List, lock all scheduled games, unlock all locked games, or unlock the whole schedule.

If not all of the requested games could be scheduled, the Scheduling Summary window displays, which provides you several options for mixing up your schedule or indicating things that should be ignored to try and help make the schedule work. Games can be left unscheduled for a number of reasons, such as timeslot conflicts or a lack of sufficient timeslots. These options allow you to experiment with different variables until you get something that works.
Help Menu

Chances are, if you're reading this manual, you've come here for some help. But there are also some built-in help options in Diamond Scheduler that can point you to tutorials and other support options. This menu also includes options for helping you manage your Diamond Scheduler subscription and your account.

Quickstart

The Quickstart option is a great tool if you're brand new to Diamond Scheduler. Clicking this option will bring up a side window, which will include instructions on creating a new schedule. As you follow the prompts in the system, the content will change to lead you through the next steps. It's very similar to the Quick Start Guide included in this document, but is slightly more interactive and available right within the software.

**Note:** This option only works if you are in a new schedule file. Create a new schedule file using the New option.

View Tutorials on the Web

Clicking this option brings you to the Tutorials page on the Diamond Scheduler web site. Here you'll find a number of movies that can walk you through a variety of basic, and some advanced, set ups and options in Diamond Scheduler.

Support on the Web

Clicking this option brings you to the Support page on the Diamond Scheduler web site. Here you'll find links to our tutorial movies, support documents, a list of FAQs, and a link for requesting further support or filing a bug if needed.
Register and Activate Diamond Scheduler

Once you've downloaded the Diamond Scheduler software, you'll need to register and activate it to be legit. When you select this option, you'll see a window to enter the license key you got in your purchase receipt email. Simply enter the key and press the Submit button.

Once you've activated, you'll see a message that the activation was successful. Additionally, the window will tell you how many activations you have left.

Deactivate this Installation

Click this option if you need to deactivate Diamond Scheduler for whatever reason, like switching to a new computer, for instance. You'll get a message that the installation was successfully deactivated.

Once you deactivate, the software will only run in demo mode until reactivated.

Check Status of Subscription

Clicking this option will show you a nifty little window that will let you check the status of your subscription. This window includes the following information:

- The status of your license (such as Valid)
- The name of the person the software is licensed to
- The license key used to activate the current instance of the software
- The email address under which the software is licensed
- The number of total activations you have
- The number of activations you have left
- The date your subscription expires on

Manage Account Online

You can use this option to access the login page on the Diamond Scheduler website. From there, you can manage your account.
About Diamond Scheduler

In case you need to provide this information for support, or just in case you're curious, you can click this option to see the version and build number of Diamond Scheduler that you're running.
A
About Diamond Scheduler, 155
Activate Diamond Scheduler, 154
Activations, 154
Add a Division, 127
Add a Special Request Game, 137
Add a Team, 130
Assign Game Numbers, 41
Available Unscheduled Timeslots, 123

C
Calendar View toolbar
   Game List, 104
Change League Type, 18
Change Teams' Divisions, 51
Check Status of Subscription, 154
Clear Recent File History, 35
Clone Games to Empty Timeslots, 47
Close Diamond Scheduler, 18
Coach Contact Sheet, 58
Coach Contacts, 58
Coaches with Multiple Teams, 58

D
Connected, 39
Copy, 31
Copy Division Games and Map to Remaining Open Timeslots, 47
Create Placeholder League for Testing, 55
Custom CSV Import, 24
Custom CSV Import window, 24
Customize Week Settings, 36

Deactivate Diamond Scheduler, 154
Deactivate this Installation, 154
Default Timeslot Colors, 36
Define Time Constraints, 132
Define Travel Constraints, 136
Delete a Division, 129
Delete a Team, 132
Diamond Scheduler
   Version number, 155
DirectLink, 19
Disconnected, 39
Division Schedules, 56
Division Timeslots Distribution, 50
Divisions
  Add, 127
  Delete, 129
  Edit, 129
Divisions tab, 126

E
  Edit a Division, 129
  Edit a Team, 132
  Edit Default HTML Reports Header and Footer, 34
  Edit menu, 30
    Copy, 31
    Paste, 31
  Preferences, 31
    Clear Recent File History, 35
    Customize Week Settings, 36
    Date and Time Formats, 37
    Edit Default HTML Reports Header and Footer, 34
  Hide Filtered Division Teams, 32
  Ignore Time and Travel Constraints for Special Requests, 39
Include Out-of-League Teams in Calendar Edit Panel, 32
Include Time in Calendar Month View, 38
Notify Me when I go Offline, 39
Open Calendar/Game List Without Data, 31
Specify Data Directory, 35
Specify Default Timeslot Colors, 36
  Exit Diamond Scheduler, 30
  Export Division Pairings, 28
  Export Division Pairings window, 28
  Export Options, 29
  Export Options window, 29
  Export Person Information, 27
  Export Person Information window, 27
  Export Report of Teams Not Playing, 62
  Export window, 25
  Exporting, 25

F
  FAQs, 154
  File menu, 15
    Change League Type, 18
Deactivate this Installation, 154
Manage Account Online, 155
Quickstart, 153
Register and Activate Diamond Scheduler, 154
Support on the Web, 154
View Tutorials on the Web, 154
Hide Filtered Division Teams, 32
Home screen, 126
  Divisions tab, 126
  People tab, 142
  Schedule tab, 144
  Teams tab, 129
  Venues tab, 139
Home Timeslot Analysis, 60

I
Ignore Time and Travel Constraints for Special Requests, 39
Import and Merge Another File, 17
Importing, 20
Include Out-of-League Teams in Calendar Edit Panel, 32
Include Time in Calendar Month View, 38

L
League subscreen, 148
License key, 154
License status, 154
Live Check for Coach Conflicts, 46
Live Check for Multiple Games for Teams, 46
Live Check for Overlapping Games for Teams, 45
Live Check for Time Constraint Conflicts, 46
Live Check for Timeslot Conflicts, 45
Live Check Options, 44
Lock All Scheduled Games in this File, 53
Lock All Schedules in this File, 52

M
Manage Account Online, 155
Master Calendar, 70
  Calendar View options, 87
  Calendar View toolbar, 76
  Filters panel, 73, 102
  Master Calendar toolbar, 75
  Right-Click options, 76
  Timeslot Detail panel, 71, 100
Move Entire Schedule, 50
Move Schedule, 50

N
New, 15
New schedules, 15
New Specialty Schedule, 16
Notify Me when I go Offline, 39
Number Games, 40

O
Open, 16
Open a file, 16
Open Calendar/Game List Without Data, 31
Open Recent, 17

P
Pairings Import window, 21
Paste, 31
Path Maps for Elimination Tournaments, 53
People tab, 142
Preferences, 31
Preferred Date and Time Formats, 37

Q
Quick Check for Coach Conflicts, 43
Quick Check for Multiple Games for Teams, 43
Quick Check for Overlapping Games for Teams, 43
Quick Check for Time Constraint Conflicts, 44
Quick Check for Timeslot Conflicts, 43
Quick Check Options, 42
Quickstart, 153

R
Register and Activate Diamond Scheduler, 154
Register Diamond Scheduler, 154
Report Options
Game List, 109
Reports menu, 56
Coach Contact Sheet, 58
Coaches with Multiple Teams, 58
Division Schedules, 56
Game Scores Reporting Sheet, 67
Team Days Off Distribution, 62
Team Games Per Week, 59
Team Home Dates Available, 60
Team Results Report, 66
Team Schedules, 57
Team Special Requests, 64
Team Time Constraints, 65
Teams Not Playing by Date, 61
Teams Playing Fewer Matchups than Others, 64
Venue Schedules, 57
Reschedule Parameters, 113

S
Save, 17
Save a file, 17, 18
Save As, 18
Schedule files, 15
Schedule tab, 144
League subscreen, 148
Tournament subscreen, 145
Show Import Formats window, 21
Show Last Schedule Problem Log, 125
Show Reschedule List, 111
Slice Timeslots, 79, 93
Special Request Games, 137
Special Requests, 64
Specialty schedules, 16
Specify Data Directory, 35
Specify Default Timeslot Colors, 36
Standings, 109
Subscription information, 154
Support on the Web, 154

T
Team Balance screen, 118
Team Balance window, 120
Team Days Off Distribution, 62
Team Game Results, 66
Team Games Per Week, 59
Team Home Dates Available, 60
Team Results Report, 66
Team Schedules, 57
Team Special Requests, 64
Team Time Constraints, 65
Team Time Constraints Import, 23
Team Time Constraints window, 23
Teams
Add, 130
Define Time Constraints, 132
Define Travel Constraints, 136
Delete, 132
Edit, 132
Special Request Games, 137
Teams Not Playing by Date, 61
Teams Playing Fewer Matchups than Others, 64
Teams tab, 129
Teams with Fewer Matchups than Others, 64
Time Constraints, 65, 132
Timeslot Calculator, 48
Timeslot Calendar, 88
   Calendar View options, 97
   Calendar View toolbar, 91
   Right-Click options, 91
   Timeslot Calendar toolbar, 90
   Timeslots Calendar panel, 98
Timeslot Division Changer, 52
Tools menu, 39
   Change Teams' Divisions, 51
   Copy Division Games and Map to Remaining Open Timeslots, 47
   Create Placeholder League for Testing, 55
   Flip Home and Away for Scheduling Patterns, 46
   Generate All Across Divisions for Existing Divisions, 46
   Live Check Options, 44
   Lock All Scheduled Games in this File, 53
   Lock All Schedules in this File, 52
   Move Entire Schedule, 50
   Number Games, 40
   Path Maps for Elimination Tournaments, 53
   Quick Check Options, 42
   Timeslot Calculator, 48
   Timeslot Division Changer, 52
   Unlock All Locked Games in this File, 53
   Unlock All Schedules in this File leaving Timeslots, 53
Tournament subscreen, 145
Travel Constraints, 136
Tutorial movies, 154

U
Unlock All Locked Games in this File, 53
Unlock All Schedules in this File leaving Timeslots, 53

V
Venue Balance window, 123
View menu, 123
Venue Schedules, 57
Venues tab, 139
Version number, 155
View

Game Balance, 114
View Balance screen, 121
View menu, 70
Available Unscheduled Timeslots, 123
Game Balance window, 116
Game List, 99
Home screen, 126
Master Calendar, 70
Show Last Schedule Problem Log, 125

Show Reschedule List, 111
Standings, 109
Team Balance, 118, 120
Timeslot Calendar, 88
View Balance, 121
View Tutorials on the Web, 154

Web support, 154
Web Tutorials, 154